[texworks] sh: repstopdf: command not found

Robinson, Edward L elr at astro.as.utexas.edu
Thu May 14 18:22:37 CEST 2020

Have just installed latest version of Texlive and TeXworks (0.6.5). A
problems has shown up with TeXworks.  

I tried to typeset the file called test1.latex with TeXworks:


My intent was to have Texworks automatically convert the eps file to a pdf file.
However, Texworks fails and returns the error message
     sh: repstopdf: command not foundsystem returned with code 32512
And then a second message that 
    File `epsfile-eps-converted-to.pdf' not found
Texworks works as expected for everything else I have tried.

Additional info:

TeXworks is set to use
with paths set to 

The following command line _does_ work as expected.
    pdflatex test1.latex
and does create the file  epsfile-eps-converted-to.pdf
(and yes, restricted \write18 enabled).
The following command line also _does_ work as expected
   epstopdf epsfile.eps epsfile-eps-converted-to.pdf
These two commands show that TeX was installed correctly and
that my shell paths are correct.

The command line command “epstopdf" is, of course, a work-around. 
But this is not how TeXworks is supposed to work.

More information about the texworks mailing list.