[texhax] problem with MathTime Pro 2 fonts and MikTeX

Stan texforeverything at att.net
Fri Jan 20 05:53:29 CET 2012

> Hello,
> ** Stan [2012-01-16 13:13:13 -0600]:
> [...]
>>> I should asked you eariler: what TeX distribution do you use? MiKTeX?
>>> TeX Live?
>> I'm using MikTeX 2.9.
> Good.


>> I ran your example, and got a log file (attached).
> I looked into it.
> Now strange thing: latex finds style file but it can't
> find font files (TFM). According to 'print.txt' they in distribution,
> could you check the following:
> 1. make sure that you copied distribution files in proper place;
>  the above 'kpsewhich' command shows that 'mtpro2.sty' file in
>  'C:/TeX/tex/texmf/tex/latex/mtpro2'
>  Is 'C:/TeX/tex/texmf' (exactly this directory!) in MiKTeX search path
>  (listed under tab 'Roots' in settings app)?

I've got "C:\TeX" listed there.  I'm assuming that's okay since that  
should include all the directories under it.

> 2. make sure that there are TFM files in  
> 'C:/TeX/tex/texmf/fonts/tfm/pctex/mtpro2'

They're there.

> In any case try the following:
> 1. Remove 'C:/TeX...' directory from 'Roots' (if it doesn't contain
> other essential TeX/LaTeX files), remove only from the LIST!, not from
> 2.
>  a) Extract distribution archive to C:\Temp\mtp2 as you do eariler.
>  b) Add directory 'C:\Temp\mtp2\texmf' to the list of 'Roots'.
>  c) Refresh file name database (FNDB),
>  d) add 'map' file to 'updmap.cfg': run
>   initexmf --edit-config-file updmap
>   and add line 'Map mtpro2.map' to it,
>  e) run
>   initexmf --mkmaps
> 3. Run latex on example file. Now it should find TFM files (font files).
> If this would work then you improperly installed MT Pro 2 (I suspect that
> latex from MiKTeX finds sty file even in wrong place but font
> files must be in proper place).

It worked, but not entirely as I thought it would.  I attached the TeX  
file, and the log and pdf.  The \exp, \cos, and \sin are all in Computer  
Modern, but the x and dotless i are in mtp2.  I haven't set up mtp2 in a  
while - obviously - but I don't remember any special commands needed for  
making stuff like \sin typeset in mtp2.  Does the log file indicate why  
that's happening?


-------------- next part --------------
A non-text attachment was scrubbed...
Name: ex2.log
Type: application/octet-stream
Size: 16916 bytes
Desc: not available
URL: <http://tug.org/pipermail/texhax/attachments/20120119/7442f9b8/attachment-0001.obj>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: ex2.ltx
Type: application/x-latex
Size: 162 bytes
Desc: not available
URL: <http://tug.org/pipermail/texhax/attachments/20120119/7442f9b8/attachment-0001.latex>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: ex2.pdf
Type: application/pdf
Size: 36718 bytes
Desc: not available
URL: <http://tug.org/pipermail/texhax/attachments/20120119/7442f9b8/attachment-0001.pdf>

More information about the texhax mailing list