[texhax] problem with MathTime Pro 2 fonts and MikTeX

Vladimir Lomov lomov.vl at gmail.com
Fri Jan 20 10:02:52 CET 2012

** Stan [2012-01-19 22:53:29 -0600]:


>>>I ran your example, and got a log file (attached).

>>I looked into it.
>>Now strange thing: latex finds style file but it can't
>>find font files (TFM). According to 'print.txt' they in distribution,
>>could you check the following:
>>1. make sure that you copied distribution files in proper place;
>> the above 'kpsewhich' command shows that 'mtpro2.sty' file in
>> 'C:/TeX/tex/texmf/tex/latex/mtpro2'
>> Is 'C:/TeX/tex/texmf' (exactly this directory!) in MiKTeX search path
>> (listed under tab 'Roots' in settings app)?

> I've got "C:\TeX" listed there.  I'm assuming that's okay since that
> should include all the directories under it.

As I said, a LaTeX engine will find sty file even if its location is wrong
(somewhere under 'C:\TeX' if the path is listed under 'Roots'). This is not a
bug, it is a feature. Font files are another beasts, dvips or font part
of pdflatex engine will search them only in specific directories.

>>2. make sure that there are TFM files in

> They're there.

>>In any case try the following:
>>1. Remove 'C:/TeX...' directory from 'Roots' (if it doesn't contain
>>other essential TeX/LaTeX files), remove only from the LIST!, not from
>> a) Extract distribution archive to C:\Temp\mtp2 as you do eariler.
>> b) Add directory 'C:\Temp\mtp2\texmf' to the list of 'Roots'.
>> c) Refresh file name database (FNDB),
>> d) add 'map' file to 'updmap.cfg': run
>>  initexmf --edit-config-file updmap
>>  and add line 'Map mtpro2.map' to it,
>> e) run
>>  initexmf --mkmaps
>>3. Run latex on example file. Now it should find TFM files (font files).

>>If this would work then you improperly installed MT Pro 2 (I suspect that
>>latex from MiKTeX finds sty file even in wrong place but font
>>files must be in proper place).

> It worked,

and as I said that means you have improperly installed MT Pro 2 distribution.
Now you have to install them correctly but afraid it could be painful.

If you wish to continue you have to be careful.

1. As you have installed MT Pro 2 manually you have to manually remove it.
Accoring to print.txt (archive listing) there are two directories in distribution:
and file 'EULA*.txt'.

AFAIU, you extract content of the archive into
so there are

If before installation there were no such directories under 'C:/TeX/tex' simply
remove them.

2. Extract context of the archive into some temporary place, for example
Then copy all directories under
directly into[1]
For example, file 'mtpro2.sty' (package 'mtpro2') must have the following path:
and TFM fonts must be in directory

[1] May be you already notice that 'C:/TeX' has special structure, there
are directories 'doc', 'fonts', 'tex' and etc. If not, take a look into
directory in which MiKTeX was installed (usually 'C:/Program Files/MiKTeX')
to get idea.

Now do steps c), d) and e).

The only left directory is 'templates'. You can copy it to
(you have to create this directory of course).

> but not entirely as I thought it would.  I attached the
> TeX file, and the log and pdf.  The \exp, \cos, and \sin are all in
> Computer Modern, but the x and dotless i are in mtp2.  I haven't set
> up mtp2 in a while - obviously - but I don't remember any special
> commands needed for making stuff like \sin typeset in mtp2.  Does
> the log file indicate why that's happening?

Do you see 'testMTP2LaTeX.pdf' file from distribution? It is in
'texmf/doc/fonts/mtpro2'. I think you find answer on your issue.

WBR, Vladimir Lomov

May you do Good Magic with Perl.
             -- Larry Wall's blessing

More information about the texhax mailing list