[texhax] problem with MathTime Pro 2 fonts and MikTeX

Vladimir Lomov lomov.vl at gmail.com
Tue Jan 17 02:28:17 CET 2012

** Stan [2012-01-16 13:13:13 -0600]:
>>I should asked you eariler: what TeX distribution do you use? MiKTeX?
>>TeX Live?

> I'm using MikTeX 2.9.

>>Could you LIST the content of the archive with MT Pro 2? For example, if
>>'mtpro2.zip' is archive with MT Pro 2 files unzip them and run in
>>command line
>>C:\Temp\mtpro2> dir

> I found "dir /s /b > print.txt" online as a way to print the file
> names to a file.  (attached)

>>Where do you unpack the archive, does your TeX distribution knows where
>>to search for that files? Run
>>C:\> kpsewhich [sty file from archive]
>>according to some PDFs this is 'mtpro2.sty', kpsewhich command provided
>>by both MiKTeX and TeX Live.

> I ran this, and the line

>    C:/TeX/tex/texmf/tex/latex/mtpro2/mtpro2.sty

> appeared.  That's probably good?
Yes, this means that latex finds the file.

>>Minimal LaTeX example:

>><example file="ex.ltx">

>>This is example.

>>The great formula $\exp^{\imath x}=\cos{x}+\imath\sin{x}$.


>>C:\Temp\test>latex -interaction=nonstopmode ex.ltx

>>P.S. I suspect that this LaTeX file could fail with 'File .. not
>>found' or
>>similar message. This would mean that tex don't find needed file and MT
>>Pro 2 is installed incorrectly.

> I ran your example, and got a log file (attached).

I looked into it.
Now strange thing: latex finds style file but it can't
find font files (TFM). According to 'print.txt' they in distribution,
could you check the following:
1. make sure that you copied distribution files in proper place;
 the above 'kpsewhich' command shows that 'mtpro2.sty' file in
 Is 'C:/TeX/tex/texmf' (exactly this directory!) in MiKTeX search path
 (listed under tab 'Roots' in settings app)?
2. make sure that there are TFM files in 'C:/TeX/tex/texmf/fonts/tfm/pctex/mtpro2'

In any case try the following:
1. Remove 'C:/TeX...' directory from 'Roots' (if it doesn't contain
other essential TeX/LaTeX files), remove only from the LIST!, not from
 a) Extract distribution archive to C:\Temp\mtp2 as you do eariler.
 b) Add directory 'C:\Temp\mtp2\texmf' to the list of 'Roots'.
 c) Refresh file name database (FNDB),
 d) add 'map' file to 'updmap.cfg': run
  initexmf --edit-config-file updmap
  and add line 'Map mtpro2.map' to it,
 e) run 
  initexmf --mkmaps
3. Run latex on example file. Now it should find TFM files (font files).

If this would work then you improperly installed MT Pro 2 (I suspect that
latex from MiKTeX finds sty file even in wrong place but font
files must be in proper place).

> The stuff that
> appeared in the terminal window while it was running looks like what
> appeared in the window at the bottom of WinEDT when I ran my
> original Plain TeX file.  One of the lines in the terminal output
> was "Couldn't find `mt2e.cfg'".  I searched myself for that file in
> my local folder and the MikTeX folder, and the local and roaming
> appdata folders, and didn't find it.  Is this something that's
> supposed to be created when running updmap?


WBR, Vladimir Lomov

Alcoholics Anonymous is when you get to drink under someone else's name.

More information about the texhax mailing list