[texhax] problem with MathTime Pro 2 fonts and MikTeX

Stan texforeverything at att.net
Mon Jan 16 20:13:13 CET 2012

On Mon, 16 Jan 2012 03:18:18 -0600, Vladimir Lomov <lomov.vl at gmail.com>  

> Hello,
> ** Stan [2012-01-15 20:14:24 -0600]:
>> On Sun, 15 Jan 2012 07:39:09 -0600, Vladimir Lomov
>> <lomov.vl at gmail.com> wrote:
>>>> I'm trying to install MathTime Pro 2 fonts to use with MikTeX 2.9
>>>> (using WinEDT 6 under Windows 7).  I used the instructions at
>>>> http://www.pctex.com/kb/56.html, but this didn't work.  I tried to
>>>> typeset this with Plain TeX:
>>>> \input mtp2
>>>> text.
>>>> \bye
>>>> but got an error.  The log file's empty, but I copied/pasted the
>>>> text that shows up at the bottom of the screen in WinEDT at the
>>>> bottom of this message.  Has anybody had the same problem, or can
>>>> anyone make sense of the errors?  I checked, and the tfm files are
>>>> in my root directory.  I also checked another installation of MikTeX
>>>> on a Windows XP computer, and everything works fine there even
>>>> though there's no file named "mt2m.cfg" there, either.
>>> Try to run
>>> C:\> initexmf --mkmaps
>>> C:\> updmap
>>> The first command should merge all updmap.cfg files into one, the  
>>> second
>>> command should generate file that pdflatex of dvips uses to produce pdf
>>> or ps file.
>> No luck.  Could there be some necessary step that the instructions
>> take for granted?  I've been refreshing the File Name Database, for
>> example, each time I try this, which is not stated anywhere in the
>> steps.  (I'm not actually sure that's required after doing it once
>> after moving the mtp2 files into my local directory, but I've been
>> doing it each time just in case.)  I wonder whether omitting
>> something like that is stopping the "real" copy of updmap.cfg from
>> being modified.
> I should asked you eariler: what TeX distribution do you use? MiKTeX?
> TeX Live?

I'm using MikTeX 2.9.

> Could you LIST the content of the archive with MT Pro 2? For example, if
> 'mtpro2.zip' is archive with MT Pro 2 files unzip them and run in
> command line
> C:\Temp\mtpro2> dir

I found "dir /s /b > print.txt" online as a way to print the file names to  
a file.  (attached)

> Where do you unpack the archive, does your TeX distribution knows where
> to search for that files? Run
> C:\> kpsewhich [sty file from archive]
> according to some PDFs this is 'mtpro2.sty', kpsewhich command provided
> by both MiKTeX and TeX Live.

I ran this, and the line


appeared.  That's probably good?

> Minimal LaTeX example:
> <example file="ex.ltx">
> \documentclass{article}
> \usepackage{mtpro2}
> \begin{document}
> This is example.
> The great formula $\exp^{\imath x}=\cos{x}+\imath\sin{x}$.
> \end{document}
> </example>
> Run:
> C:\Temp\test>latex -interaction=nonstopmode ex.ltx
> P.S. I suspect that this LaTeX file could fail with 'File .. not found'  
> or
> similar message. This would mean that tex don't find needed file and MT
> Pro 2 is installed incorrectly.

I ran your example, and got a log file (attached).  The stuff that  
appeared in the terminal window while it was running looks like what  
appeared in the window at the bottom of WinEDT when I ran my original  
Plain TeX file.  One of the lines in the terminal output was "Couldn't  
find `mt2e.cfg'".  I searched myself for that file in my local folder and  
the MikTeX folder, and the local and roaming appdata folders, and didn't  
find it.  Is this something that's supposed to be created when running  


-------------- next part --------------
A non-text attachment was scrubbed...
Name: ex.log
Type: application/octet-stream
Size: 25059 bytes
Desc: not available
URL: <http://tug.org/pipermail/texhax/attachments/20120116/7cfbca6c/attachment-0001.obj>
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: print.txt
URL: <http://tug.org/pipermail/texhax/attachments/20120116/7cfbca6c/attachment-0001.txt>

More information about the texhax mailing list