[texhax] problem with MathTime Pro 2 fonts and MikTeX

Vladimir Lomov lomov.vl at gmail.com
Mon Jan 16 10:18:18 CET 2012

** Stan [2012-01-15 20:14:24 -0600]:

> On Sun, 15 Jan 2012 07:39:09 -0600, Vladimir Lomov
> <lomov.vl at gmail.com> wrote:

>>>I'm trying to install MathTime Pro 2 fonts to use with MikTeX 2.9
>>>(using WinEDT 6 under Windows 7).  I used the instructions at
>>>http://www.pctex.com/kb/56.html, but this didn't work.  I tried to
>>>typeset this with Plain TeX:

>>>\input mtp2



>>>but got an error.  The log file's empty, but I copied/pasted the
>>>text that shows up at the bottom of the screen in WinEDT at the
>>>bottom of this message.  Has anybody had the same problem, or can
>>>anyone make sense of the errors?  I checked, and the tfm files are
>>>in my root directory.  I also checked another installation of MikTeX
>>>on a Windows XP computer, and everything works fine there even
>>>though there's no file named "mt2m.cfg" there, either.

>>>>Use search engines, Stan. For example, google gives me these:

>>>I found those pages too.  Reinstalling as suggested in the first
>>>page didn't fix the error I'm getting.  (Mine's similar but not
>>>identical to the one on the sourceforge page.)
>>W/o minimal example (LaTeX one would be perfect) and its log generated
>>by pdf[la]tex it is difficult to find the source of the problem.

> The example from my original email is the smallest I used, but it
> doesn't even get far enough to put anything in the log file.  A log
> file is created, but it's empty.
I meant LaTeX one.

>>>>P.S. Did you try MT Pro 2 with LaTeX?

>>>Yes, with no luck.

>>>I might have found the problem, but I still don't know how to solve
>>>it.  I decided to open "updmap.cfg" in a text editor, and saw that
>>>it doesn't have the lines from step 5 in
>>>http://www.pctex.com/kb/56.html.  I searched for other files with
>>>the same name, and found one in my "roaming" folder under "appdata".
>>>It was created when I did step 4.  It contains only the following

>>>%% T1 font configuration settings. See the MiKTeX manual for help.
>>># MathTimePro II
>>>Map mtpro2.map
>>I don't have Windows machine and MiKTeX right now at hand to check but
>>"roaming" directory seems ok.

>>>It doesn't seem to matter what directory I'm in when I run the
>>>initexmf line and the updmap line in steps 4 and 7.  It's not
>>>modifying the right copy of updmap.cfg.  (Or what I think it the
>>>right copy, the one under C:\Program Files (x86)\MikTeX\....)  I
>>>can't modify that file directly in a text editor, since I don't have
>>>permission to save to its location.  Making a copy of it in My
>>>Documents, modifying it in a text editor, and then replacing the
>>>original with that copy didn't work.  Do you know if that's the copy
>>>that needs to be changed?  I couldn't find anything in the MikTeX
>>>manual about it.

>>Try to run
>>C:\> initexmf --mkmaps
>>C:\> updmap

>>The first command should merge all updmap.cfg files into one, the second
>>command should generate file that pdflatex of dvips uses to produce pdf
>>or ps file.

> No luck.  Could there be some necessary step that the instructions
> take for granted?  I've been refreshing the File Name Database, for
> example, each time I try this, which is not stated anywhere in the
> steps.  (I'm not actually sure that's required after doing it once
> after moving the mtp2 files into my local directory, but I've been
> doing it each time just in case.)  I wonder whether omitting
> something like that is stopping the "real" copy of updmap.cfg from
> being modified.

I should asked you eariler: what TeX distribution do you use? MiKTeX?
TeX Live?

Could you LIST the content of the archive with MT Pro 2? For example, if
'mtpro2.zip' is archive with MT Pro 2 files unzip them and run in
command line
C:\Temp\mtpro2> dir

Where do you unpack the archive, does your TeX distribution knows where
to search for that files? Run
C:\> kpsewhich [sty file from archive]
according to some PDFs this is 'mtpro2.sty', kpsewhich command provided
by both MiKTeX and TeX Live.

Minimal LaTeX example:

<example file="ex.ltx">

This is example.

The great formula $\exp^{\imath x}=\cos{x}+\imath\sin{x}$.


C:\Temp\test>latex -interaction=nonstopmode ex.ltx

P.S. I suspect that this LaTeX file could fail with 'File .. not found' or
similar message. This would mean that tex don't find needed file and MT
Pro 2 is installed incorrectly.

WBR, Vladimir Lomov

The meta-Turing test counts a thing as intelligent if it seeks to
devise and apply Turing tests to objects of its own creation.
		-- Lew Mammel, Jr.

More information about the texhax mailing list