[tlu] Yosemite workaround

Richard Koch koch at math.uoregon.edu
Tue Aug 5 21:24:37 CEST 2014


I have good news and bad news, but mostly good news.

I reinstalled BaicTeX-2014, so I had a version that needed updating. Then
I used the earlier 1.18b8 and your suggested:

	$ export NSUnbufferedIO=YES 
$ /Applications/TeX/TeX\ Live\ Utility.app/Contents/MacOS/TeX\ Live\ Utility 

TLU correctly updated BasicTeX, ran updmap-sys without problems, and reported
success in the end. Well done!

Then I downloaded 1.18b9. But trying to run it, Yosemite puts up a dialog
saying “This application is damaged and should be moved to the trash.” 
I tried the trick of holding down the control key and choosing to run in spite
of the warning, but that didn’t work. The dialog didn’t change.

Maybe you tried to sign and failed? I got a message this morning saying that
the signing method is changing and you must sign with the version of Xcode
just released for Yosemite, or else the version on the newest beta of Mavericks
(I don’t have that newest Mavericks).

But I think you basically know what to do.


> On Aug 5, 2014, at 11:15 AM, Adam R. Maxwell <amaxwell at mac.com> wrote:
> For anyone experiencing problems with Yosemite, I've released 
> 1.18b9 which hopefully works around the problem.
> https://github.com/amaxwell/tlutility/releases

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://tug.org/mailman/private/tlu/attachments/20140805/365f4941/attachment-0001.html>

More information about the tlu mailing list