[tlu] Yosemite workaround

Adam R. Maxwell amaxwell at mac.com
Tue Aug 5 21:46:52 CEST 2014

On Aug 5, 2014, at 12:24 , Richard Koch <koch at math.uoregon.edu> wrote:

> 	$ export NSUnbufferedIO=YES 
> $ /Applications/TeX/TeX\ Live\ Utility.app/Contents/MacOS/TeX\ Live\ Utility 
> TLU correctly updated BasicTeX, ran updmap-sys without problems, and reported
> success in the end. Well done!

Well, that's what I really needed to know…thanks for the check!
Apparently Apple has changed something in the system that screws up
shell scripts and pipes. NSUnbufferedIO is pretty much undocumented,
so I suppose I should try filing a radar. Logging /usr/bin/env is
probably the best thing I ever did in TLU for debugging :-).

> Then I downloaded 1.18b9. But trying to run it, Yosemite puts up a dialog
> saying “This application is damaged and should be moved to the trash.” 
> I tried the trick of holding down the control key and choosing to run in spite
> of the warning, but that didn’t work. The dialog didn’t change.

That is odd. I've seen it once or twice with other programs, and usually
re-downloading will fix it. Safari screws something up, I think
(and I just downloaded and ran it to be sure).

> Maybe you tried to sign and failed? I got a message this morning saying that
> the signing method is changing and you must sign with the version of Xcode
> just released for Yosemite, or else the version on the newest beta of Mavericks
> (I don’t have that newest Mavericks).

I'm on the latest beta of Mavericks right now, but using Xcode 5.1.1.
I've already gone through the pain of signing all of my python scripts,
plugins, and frameworks manually, though. It's self-signed, so it won't
be perfectly seamless.


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://tug.org/mailman/private/tlu/attachments/20140805/b6497fea/attachment.html>

More information about the tlu mailing list