[tlbuild] problem reautoconf-ing TL

Norbert Preining preining at logic.at
Tue Sep 1 15:33:44 CEST 2009

Hi Peter,

while trying to fix the missing -DHAVE_KPATHSEA by adding I tried to
reautoconf, but that worked out badly: generated configure scripts 
with syntax errors:

./reautoconf: using "autoconf" = autoconf (GNU Autoconf) 2.64
./reautoconf: using "autoheader" = autoheader (GNU Autoconf) 2.64
./reautoconf: using "automake" = automake (GNU automake) 1.11
./reautoconf: using "aclocal" = aclocal (GNU automake) 1.11

(so a bit newer than 2.63 which you are running).

The problem is that there are syntax errors in all the configure scripts:
..../configure: line NNNNN: `esac# Check whether --enable-.....

I found another instance where
was created when only reautoconfing texk/lcdf-typtools

I have tried to find the reason for that, but didn't succeed. It looks
somehow puzzling.

Then, could you somehow make that -DHAVE_CONFIG is automatically added
to all the Makefiles generated below lcdf-typetools, that seems
to be nessary to actually search for files using kpathsea.

Best wishes


Dr. Norbert Preining <preining at logic.at>        Vienna University of Technology
Debian Developer <preining at debian.org>                         Debian TeX Group
gpg DSA: 0x09C5B094      fp: 14DF 2E6C 0307 BE6D AD76  A9C0 D2BF 4AA3 09C5 B094
A late-night snack, invented by the Earl of Nantwich, which consists
of the dampest thing in the fridge, pressed between two of the driest
things in the fridge. The Earl, who lived in a flat in Clapham,
invented the nantwich to avoid having to go shopping.
			--- Douglas Adams, The Meaning of Liff

More information about the tlbuild mailing list