[texworks] Broken installation. Can't process ConTeXt files.

Herbert Schulz herbs at wideopenwest.com
Fri Jun 21 23:22:47 CEST 2013

On Jun 21, 2013, at 12:35 PM, Hugh Sparks <hugh at csparks.com> wrote:

> I'm a new MiKTeX user, trying to migrate from texlive.
> My source files are in ConTeXt.
> After installing and running TeXworks, I was able to drag-n-drop a source file into the workspace window and see the pdf output almost instantly. Very impressive!
> Then I foolishly tried to change the setting in the Typeset menu from:
>    PdfLaTex+MakeIndex+BibTeX
> To:
>   ConTeXt (pdfTeX)
> When I ran typeset again, it failed with the console output showing an "Undefined control sequence for \definepapersize. I put the Typeset menu selection back to the original value, but now it never works, always failing to find the \definepapersize directive. I tried all the other typeset menu selections with the same result. Finally I removed the entire MiKTeX package and re-installed it. It still doesn't work. Somewhere a configuration file is left behind that keeps the package from working as originally installed.
> How can I get ConTeXt working again?
> If I may add a related question, how could I process a ConTeXt source file to create a pdf using the command line?
> Thanks for helping an ignorant beginner. I tried to find information about running context in both the manual and the FAQ file without success.


Context is a completely separate macro set than LaTeX so trying to compile a LaTeX file using Context just won't work.

Good Luck,

Herb Schulz
(herbs at wideopenwest dot com)

More information about the texworks mailing list