[texworks] Broken installation. Can't process ConTeXt files.

Hugh Sparks hugh at csparks.com
Fri Jun 21 19:35:01 CEST 2013

I'm a new MiKTeX user, trying to migrate from texlive.
My source files are in ConTeXt.
After installing and running TeXworks, I was able to drag-n-drop a 
source file into the workspace window and see the pdf output almost 
instantly. Very impressive!

Then I foolishly tried to change the setting in the Typeset menu from:



    ConTeXt (pdfTeX)

When I ran typeset again, it failed with the console output showing an 
"Undefined control sequence for \definepapersize. I put the Typeset menu 
selection back to the original value, but now it never works, always 
failing to find the \definepapersize directive. I tried all the other 
typeset menu selections with the same result. Finally I removed the 
entire MiKTeX package and re-installed it. It still doesn't work. 
Somewhere a configuration file is left behind that keeps the package 
from working as originally installed.

How can I get ConTeXt working again?

If I may add a related question, how could I process a ConTeXt source 
file to create a pdf using the command line?

Thanks for helping an ignorant beginner. I tried to find information 
about running context in both the manual and the FAQ file without success.

----- configuration info -----
TeXworks version : 0.4.4r1003 (MiKTeX 2.9 64-bit)
Install location : C:/Program Files/MiKTeX 
Library path : C:/Users/Hugh/AppData/Local/MiKTeX/2.9/TeXworks/0.4\
pdfTeX location : C:/Program Files/MiKTeX 2.9/miktex/bin/x64/pdftex.exe
Operating system : Windows Microsoft Windows 7 Ultimate Edition, 64-bit 
Service Pack 1 (build 7601)
Qt4 version : 4.7.2 (build) / 4.8.4 (runtime)

Mail: hugh at csparks.com
Office: 952-955-2800
Mobile: 612-247-2714

More information about the texworks mailing list