TexLive 2019 and 2018 issue

Spyros spyrosfronimos at gmail.com
Mon Jul 15 21:09:58 CEST 2019

Good evening.
I recently installed Texlive 2018 in my pc in order to move from Miktex to
Texlive. The moment that the installation was finished I tried to compile
the following MWE


but no matter what I try to get it working I get this error

*Use of uninitialized value $ver in scalar chomp at
C:/texlive/2018/tlpkg/TeXLive/TLWinGoo.pm line 204. Use of uninitialized
value $ver in substitution (s///) at
C:/texlive/2018/tlpkg/TeXLive/TLWinGoo.pm line 205. Use of uninitialized
value $ver in substitution (s///) at
C:/texlive/2018/tlpkg/TeXLive/TLWinGoo.pm line 205.fmtutil: fmtutil is
using the following fmtutil.cnf files (in precedence order): fmtutil:
c:/texlive/2018/texmf-dist/web2c/fmtutil.cnf fmtutil: fmtutil is using the
following fmtutil.cnf file for writing changes: fmtutil:
c:/users/spyros/.texlive2018/texmf-config/web2c/fmtutil.cnf fmtutil [INFO]:
writing formats under c:/users/spyros/.texlive2018/texmf-var/web2c fmtutil
[INFO]: --- remaking pdflatex with pdftexCan't spawn "cmd.exe": No such
file or directory at c:\texlive\2018\texmf-dist\scripts\texlive\fmtutil.pl
<http://fmtutil.pl> line 598. fmtutil [WARNING]: inifile pdflatex.ini for
pdflatex/pdftex not found.fmtutil [INFO]: Disabled formats: 6 fmtutil
[INFO]: Not selected formats: 28 fmtutil [INFO]: Failed to build: 1
(pdftex/pdflatex) fmtutil [INFO]: Total formats: 35 fmtutil [INFO]: exiting
with status 1C:\texlive\2018\bin\win32\runscript.tlu:907: command failed
with exit code 1: perl.exe
c:\texlive\2018\texmf-dist\scripts\texlive\fmtutil.pl <http://fmtutil.pl>
--user --byfmt pdflatexRunning the command
C:\texlive\2018\bin\win32\fmtutil-user.exekpathsea: Running mktexfmt
pdflatex.fmt The command name is C:\texlive\2018\bin\win32\mktexfmt*

I got the same error with Texlive 2019 thats why I tried to install an
older version. Also I want to mention that the update isn't working and
that I have MikTex installed as well so I can get my work done until
Texlive is working. Any thoughts?

I read that these kind of errors are caused by Perl issues. I have a full
installation of Strawberry Perl in my computer and still this does got fix
the error. I have also added TexLive variable to the PATH, placed above

In my other computer I have the same Texlive and Texstudio installation
without the need to install Perl as everything works.

Thank you.


από ιούς. www.avast.com
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://tug.org/pipermail/texhax/attachments/20190715/c4f345f3/attachment.html>

More information about the texhax mailing list