[texhax] Trouble Installing MacTeX

Thomas Schneider schneidt at mail.nih.gov
Fri Jul 12 05:56:43 CEST 2013


> I'm the guy who made previous versions of MacTeX and made this year's
> version.

Ok, great!!

> The goal was to make this year's installation from the DVD as easy
> as in the past, with a little more feedback to the user. In
> particular, everything that happened in the past should still have
> happened this time, including correct permissions on 2013, paths
> using /usr/texbin, and correctly setting shell paths.  Karl Berry
> wrote you, but unfortunately I disagree with almost everything he
> wrote.  (Sorry Karl).
> Before we made the DVD, I used the instructions to install MacTeX on
> every single system we support: Leopard, Snow Leopard, Lion,
> Mountain Lion (and even, when the beta appeared, Mavericks). I
> didn't run into a permission problem, or any other problem, on any
> of these systems. So the goal of this email is to figure out why you
> had trouble.


> -------------
> Let's start with what should have happened. The Part I instructions
> end with
> the message:
> "Terminal will ask for a password -- and may print a scary message
> if this is the first time the sudo command has been used. Enter your
> ordinary password as a user with Admin privileges. TeX Live will
> install without further ado. At the end, some information will be
> printed in Terminal, but this information can be ignored."
> As you see, you were supposed to ignore the instruction `Most
> importantly,
> add /usr/local/texlive/2013/bin/x86_64-darwin
> to your PATH for current and future sessions.' This applies to other
> Unix systems, but not the Mac.

I missed the bit about NOT following some instructions, but adding
that to my path didn't help so I removed it.

> Is it possible that you tried to use the system after Part 1 BEFORE
> you installed Part II? That would not work, because Part II fixes
> shell paths, sets up the MacTeX data structure, and changes
> /usr/texbin.

I had the same problem on four different systems, 10.6.8 and a 10.7.

As far as I know in every case I the entire install in each case. 
Having done so I could not get access to latex from the command line
of a fresh terminal.  As you know, the reason wasn't the path, it was
the permissions.

> OK, after Part I, Part II should have worked exactly as in past years,
> since it
> does exactly what was done in the past, but without having to install
> MacTeX.
> You have an older system and cannot use the latest versions of TeXShop
> or TeXworks, so part III applies to you. But your old TeXShop and
> TeXworks
> should have been left in place; said another way, part III isn't really
> required for
> a user who is upgrading.

Oh well, I followed it.  But I don't use TeXShop anyway, I use vim and
trigger a script to do the typesetting using my atchange program.  I
use Skim to display.  This gives me a very big terminal to edit in,
efficient editing (in vim) AND I get the typeset version shown
immediately without taking my hands off the keyboard.  (I map ',' to
mean to write the file out and atchange triggers on the file change).

> ---------------
> Now on to your message. You SHOULD NOT change path; this year, as in
> the past, the correct path is /usr/texbin and will be set
> automatically by the installer.


> The key question is why your permissions for 2013 are  drwx------ ,
> rather than the correct drwxr-xr-x. We ran into this permission
> problem last year with a small number of users. Our conjecture is
> that these people also use "HomeBrew", a port system similar to
> MacPorts. We suspect this because the HomeBrew folks recommend that
> /usr/local be entirely owned by the user rather than having
> permissions wxrw-rw-r.  I suspect that the TeX Live Script sees this
> and sets the 2013 permissions similarly.  After we ran into this
> problem, he first version of MacTeX CHANGED PERMISSIONS for
> /usr/local to fix the problem. But I was later convinced that this
> was an undesirable move, and that users who have unusual /usr/local
> permissions need to learn to deal with the consequences.
> -----------------
> Can you shed light on what happened in your case? Do you use HomeBrew?

Nope.  I didn't know about HomeBrew until after I sent my message out
and I have never used it!

> What
> permissions do you have for the directories
> /usr
> /usr/local
> /usr/local/texlive

They are all drwxr-xr-x.

> Is there any other reason that 2013 would have been given incorrect
> permissions?

As we found in previous emails, when I am sudo the permissions are:

% sudo umask -S

So any files are set that way.  I didn't set the sudo mask.  It must
be somewhere in the OS and it must be a standard Mac setting.

> I'm rushing off this email. If you reply that all of my home brew
> conjectures are false, I'll reinstall MacTeX one final time to see
> if I see similar permission problems, but I strongly suspect that I
> won't.

Yup, home brew seems to be unrelated to the problem.

Thanks for looking into this.

All of my 5 systems are now installed.  In each case latex was
inaccessible after the TexLive install but after I did the recursive

   cd /usr/local/texlive
   sudo chmod -R a+rX 2013

they all run fine.

I don't have the DVD with me so can't check right now, but maybe the
permissions in the files there are disallowing group and other?


  Thomas D. Schneider, Ph.D.
  Senior Investigator
  National Institutes of Health
  National Cancer Institute
  Center for Cancer Research
  Gene Regulation and Chromosome Biology Laboratory
  Molecular Information Theory Group
  Frederick, Maryland  21702-1201
  schneidt at mail.nih.gov
  http://schneider.ncifcrf.gov/(current link)
  http://alum.mit.edu/www/toms (permanent link)

More information about the texhax mailing list