[texhax] can't find input file?

Eric Abrahamsen girzel at gmail.com
Mon Feb 8 10:26:28 CET 2010

I've been working on a tex file recently that makes use of two style  
files, one of which loads the other. I want to use these style files  
for other tex files, so this morning I tried putting them some place  
on my system where they'd be located automatically by my latex  
installation (I'm using MacTex 2009).

I can't be sure, but it seems like as soon as I moved the style files,  
I started getting the error that LaTeX couldn't find my input file  
(called "northern.tex" in this case). Not that it couldn't find my  
style files, but the input file itself. I assumed the error message  
was borked somehow and continued moving the style files to various  
places around my system and messing with environment variables.

Nothing worked, so I put the style files back in the directory with  
the input file. Same error. The input file is very obviously there,  
and not empty, and yet both Auctex via Emacs and the command line say  
they can't find the input file. I've removed the \usepackage commands  
and all custom commands from the input file, so it's basically just a  
standard LaTeX file with nothing but text. Same error with XeTeX and  
LaTeX. Here's the XeTeX log output:

This is XeTeX, Version 3.1415926-2.2-0.9995.2 (TeX Live 2009)  
(format=xetex 2009.11.7)  8 FEB 2010 17:23
entering extended mode
  %&-line parsing enabled.

! Emergency stop.
<*> northern.tex

End of file on the terminal!

No pages of output.

How can it reach end of file when the file's right there in the  



More information about the texhax mailing list