[tex-live] dvipdfmx on CentOS 5.6 (glibc 2.5)

Zdenek Wagner zdenek.wagner at gmail.com
Sat Apr 14 10:38:07 CEST 2012

2012/4/14 Karen Ellrick <osakawebbie at gmail.com>:
> I hope this is the right list for this issue - I couldn't find another one
> that was more appropriate.
> I just installed TeXLive on CentOS 5.6 using install-tl, and the installer
> chose the x86_64-linux package, which seems correct.  If it matters, I'm
> using uptex (installed on top of TeXLive using tlmgr) because I need its
> Japanese features.  That part runs with no errors on a basic test file, but
> when I try to run dvipdfmx on the resulting dvi file, I get the following:
> dvipdfmx: /lib64/libc.so.6: version `GLIBC_2.7' not found (required by
> dvipdfmx)
> I'm not a Linux expert, but I know how to use Google.  Running "ldd
> --version" tells me that I have GNU libc 2.5.  One's first thought might be
> to upgrade my system so that it has 2.7, but advice to others in this
> situation is to avoid changing what's on the given machine, because libc is
> finely tuned to go with a variety of other functionality (I certainly don't
> want to break other things).
Strange, I have just tried dvipdfmx from TL2011 on GentOS 4.7 and 5.3
and I managed to process a simple DVI.

> Is there a build of dvipdfmx that works with glibc 2.5?  Or do I need to
> build my own?  (If so, please give me some instructions - I can do simple
> "configure", "make", and "make install" if the configuration files exist,
> but if it is much more difficult than that, I'll need help.)  Thanks!
I tried to build the whole TL (without xindy) from the svn sources. It
always worked. Just run Build in the Build/source directory

> Aside: Doing this from the command line is just a testing step - I will
> ultimately be using PHP to build a tex file dynamically, calling the needed
> command(s) to produce a PDF file, and presenting that to the user.  It would
> be cleaner to go from the layout file directly to PDF (i.e. pdftex), but I
> need vertical writing and UTF-8, which forces me to use uptex, and there is
> no such thing as "uppdftex".  For testing right now, I wish I could "see"
> the test dvi somehow to know that uptex worked okay - I looked through the
> commands and spotted two whose names looked promising, but experimenting
> with them was not productive:
> [root at vps-1011517-5697 ~]# dvi2tty aozora-utarticle-utf8-1.dvi
> dvi2tty: Id-byte is not correct: 3
>  [root at vps-1011517-5697 ~]# dvipng aozora-utarticle-utf8-1.dvi
> This is dvipng 1.14 Copyright 2002-2010 Jan-Ake Larsson
> [1
> dvipng: Fatal error, undefined DVI op-code 255
> If those errors are documented, I'm not looking in the right place.  Anyway,
> any guidance is appreciated.

Zdeněk Wagner

More information about the tex-live mailing list