[OS X TeX] \input and Texroot

Nitecki, Zbigniew H. Zbigniew.Nitecki at tufts.edu
Sat May 31 16:35:07 CEST 2014

Thanks to you and Herbert (and Dave Derbes) for your responses.  It seems no one has an idea what is going on, and I will just have to schlep along as best I can

To answer two questions: 
I copied one file at a time because this way I easily keep track of where I am in my initial revision process. 
All sections (including exercise files) are called directly from the central file. 

My primary puzzlement is that the first three sections (including exercises) behave exactly as expected. And I have checked extensively for typos in the file names. 


Sent from my iPad

> On May 31, 2014, at 9:25 AM, "Alain Schremmer" <schremmer.alain at gmail.com> wrote:
>> On May 31, 2014, at 7:37 AM, Nitecki, Zbigniew H. wrote:
>> I am experiencing a problem for which I don't know how to provide a minimal example, and have no idea even where to look for a cause.
>> I have been working on a book for some time, in which the individual sections are in separate files, named <section>.tex, and the accompanying exercises in files named <section>.ex.tex.  The master file, CalcThree.tex, calls them via \input{<section>}
>> (resp. \input{<section>.ex}).  Each of the individual files starts with
>>> %!TEX root =  CalcThree.tex
>> All of these are in a single folder.
>> I had a fully functioning version of this book, but need to do a major rewrite/revision.  So I created a new folder, and am one-by-one duplicating the section files, moving it to the new folder, renaming the file <section>.tex copy (reps. <section>.ex.tex) as  <section>14.tex (resp. <section>14.ex.tex), changing the root to
>>> %!TEX root =  CalcThree14.tex
>> changing my \input calls, and doing my revisions there.
>> All was going fine until I got to the exercises for the fourth section, originally in file dot.ex.tex.  I have the following weird situation: if I hit the "Typeset" tab from file dot14.ex.tex, the compiler works away on compiling the book until it gets to \input{dot14.ex} where it stops and gives me the error message: can't find file dot14.ex.  Same if I typeset from CalcThree14.tex.
>> What can possibly be going on, or more to the point, how can I work around this?  I've tried various versions of explicitly adding the .tex to calls, renaming the file, etc., all to no avail.
> This person has of course no idea but in somewhat similar situations, what I have done is to give up and make a new copy of the functioning version etc. Not a very scientific approach of course but it has worked each time.  :-(
> By the way, I am curious as to why you duplicated the sections one by one rather than duplicate the whole folder.
> Regards
> -schremmer
> ----------- Please Consult the Following Before Posting -----------
> TeX FAQ: http://www.tex.ac.uk/faq
> List Reminders and Etiquette: http://email.esm.psu.edu/mac-tex/
> List Archive: http://tug.org/pipermail/macostex-archives/
> TeX on Mac OS X Website: http://mactex-wiki.tug.org/
> List Info: https://email.esm.psu.edu/mailman/listinfo/macosx-tex

More information about the macostex-archives mailing list