[OS X TeX] \input and Texroot

Herbert Schulz herbs at wideopenwest.com
Sat May 31 15:36:58 CEST 2014

On May 31, 2014, at 6:37 AM, Nitecki, Zbigniew H. <Zbigniew.Nitecki at tufts.edu> wrote:

> I am experiencing a problem for which I don't know how to provide a minimal example, and have no idea even where to look for a cause.
> I have been working on a book for some time, in which the individual sections are in separate files, named <section>.tex, and the accompanying exercises in files named <section>.ex.tex.  The master file, CalcThree.tex, calls them via \input{<section>}
> (resp. \input{<section>.ex}).  Each of the individual files starts with
>> %!TEX root =  CalcThree.tex
> All of these are in a single folder.
> I had a fully functioning version of this book, but need to do a major rewrite/revision.  So I created a new folder, and am one-by-one duplicating the section files, moving it to the new folder, renaming the file <section>.tex copy (reps. <section>.ex.tex) as  <section>14.tex (resp. <section>14.ex.tex), changing the root to
>> %!TEX root =  CalcThree14.tex
> changing my \input calls, and doing my revisions there.
> All was going fine until I got to the exercises for the fourth section, originally in file dot.ex.tex.  I have the following weird situation: if I hit the "Typeset" tab from file dot14.ex.tex, the compiler works away on compiling the book until it gets to \input{dot14.ex} where it stops and gives me the error message: can't find file dot14.ex.  Same if I typeset from CalcThree14.tex.
> What can possibly be going on, or more to the point, how can I work around this?  I've tried various versions of explicitly adding the .tex to calls, renaming the file, etc., all to no avail.
> Zbigniew Nitecki
> Department of Mathematics
> Tufts University
> Medford, MA 02155
> telephones:
> Office    (617)627-3843
> Dept.    (617)627-3234
> Dept. fax    (617)627-3966
> http://www.tufts.edu/~znitecki/


Are all the \input commands in the root file or is the \input file for the exercises in the section file? If you ``typeset'' the section file does it go through? I also wonder why you didn't just duplicate the whole folder. Also, while it shouldn't make a difference, it is bad practice to use a period as part of the file name; something like <section>.tex and <section>X.tex would be better. Finally, you say you tried to change the file name, how about making sure the \input command is correct without extra characters.

Good Luck,

Herb Schulz
(herbs at wideopenwest dot com)

More information about the macostex-archives mailing list