[OS X TeX] Trouble with undefined references using Chapter bibliographies

Herbert Schulz herbs at wideopenwest.com
Mon Oct 18 10:34:38 CEST 2010

On Oct 18, 2010, at 2:17 AM, Anand Ramaswamy wrote:

> Thanks. Actually I want to have individual chapter bibliographies -a
> unique one for each chapter and not one big bibliography in the root
> file. I use bibdesk to create the .bib files and I include them in the
> individual chapter files. In the root file I use the package
> {chapterbib} along with including the chapter files using \include.
> Like I mentioned in my previous post I Run LATEX (to generate the
> chapter .aux files); run BibTEX on each included file; run LATEX; run
> LATEX again.  However, when I do this I get a warning of undefined
> references when i run latex on the root file and although the
> bibliography shows up in the document the references show up as [?].
> Thanks for your help.


Is there any way you can supply a minimal example (i.e., a root file and a couple of minimal included files along with some bibliography references --- something that I can compile and play with)? I haven't used chapterbib at all and want to check it out.

It could just mean that you need to make one more run of latex on the document to resolve those references.

Good Luck,

Herb Schulz
(herbs at wideopenwest dot com)

More information about the macostex-archives mailing list