[OS X TeX] Trouble with undefined references using Chapter bibliographies

Herbert Schulz herbs at wideopenwest.com
Mon Oct 18 17:19:37 CEST 2010

On Oct 18, 2010, at 2:17 AM, Anand Ramaswamy wrote:

> Thanks. Actually I want to have individual chapter bibliographies -a
> unique one for each chapter and not one big bibliography in the root
> file. I use bibdesk to create the .bib files and I include them in the
> individual chapter files. In the root file I use the package
> {chapterbib} along with including the chapter files using \include.
> Like I mentioned in my previous post I Run LATEX (to generate the
> chapter .aux files); run BibTEX on each included file; run LATEX; run
> LATEX again.  However, when I do this I get a warning of undefined
> references when i run latex on the root file and although the
> bibliography shows up in the document the references show up as [?].
> Thanks for your help.


Well, I hacked together a ``book'' with two chapters included in the root.tex file and used the chapterbib package and the plain bibliographystyle. Compiling with the pdflatexmk engine (you can just substitute the latexmk engine and it will work too) automatically did all the necessary work and the individual bibliographies for each chapter showed up along with the citations.

I don't know if this realistically matches what you are doing so a sample set of files would still be helpful.

Just to be sure... are you using Terminal to compile the document? What editor or front end are you using?

Good Luck,

Herb Schulz
(herbs at wideopenwest dot com)

More information about the macostex-archives mailing list