[OS X TeX] TeX Live Utility

Paul Fons paul-fons at aist.go.jp
Sun Feb 15 17:36:27 CET 2009

Thanks for the quick reply.
On Feb 16, 2009, at 1:26 AM, Adam R. Maxwell wrote:

> On Feb 15, 2009, at 12:51 AM, Paul Fons wrote:
>> I am a little confused.  My TeX Live Utility worked fine when I  
>> used it the first few times.  Now, however, I am running into what  
>> appears to be the same error mentioned earlier in the mail list  
>> caused by having fink earlier in the search path.
> Do you have any idea when this may have started?

As I recall, the first version of TeXLive utility had a problem when  
it was first released.  I updated a second version after it was  
updated and I successfully updated my distribution without an  
problems.  When I went back some time later to see if there were any  
additional updates, the problems I forwarded occurred.  I do not think  
I had changed any paths to that point, but I have certainly fooled  
around with them without success since the problem started.
>> The problem, however, is that fink is not the first thing in the  
>> search path.  The log from TeXLive is pasted below.  A terminal  
>> session shows the path:
>> ~ $echo $PATH
>> /Library/Frameworks/Python.framework/Versions/Current/bin:/opt/ 
>> openmpi/bin:/usr/texbin:/sw/bin:/usr/bin:/bin:/usr/sbin:/sbin:/usr/ 
>> local/bin:/usr/texbin:/usr/X11/bin:/opt/feff/feff85:/texprograms:/ 
>> opt/etsf/abinit/5.6/bin:/usr/X11R6/bin:/Users/paulfons/bin/FDK/ 
>> Tools/osx
> This should all be ignored by TLU.
>> The bits from TeXLive Utility are reproduced below.  I have no idea  
>> where the Path environment is being set, but I don't see fink on  
>> it.  Any ideas?
>> 2009-02-15 16:57:50 +0900 Notice +[TLMAppController  
>> updatePathEnvironment][2305]	Using PATH = "(
>>   "/usr/bin",
>>   "/bin",
>>   "/usr/sbin",
>>   "/sbin",
>>   "/usr/local/bin",
>>   "/usr/texbin"
>> )"
> This looks correct, and you don't have environment.plist to foul  
> things up.  Try this in Terminal, since it's exactly what's being  
> run in TLU:
> export PATH="/usr/bin:/bin:/usr/sbin:/sbin:/usr/local/bin:/usr/texbin"
> tlmgr --machine-readable >/dev/null

Looks like a problem.  Might the underlying cause of this happened as  
a consequence of the update?

Last login: Mon Feb 16 00:50:44 on ttys003
~ $export PATH="/usr/bin:/bin:/usr/sbin:/sbin:/usr/local/bin:/usr/ 
~ $tlmgr --machine-readable >/dev/null
Can't locate TeXLive/TLPOBJ.pm in @INC (@INC contains: /usr/tlpkg /sw/ 
lib/perl5/5.8.8/darwin-thread-multi-2level /sw/lib/perl5/5.8.8 /sw/lib/ 
perl5/darwin-thread-multi-2level /sw/lib/perl5 /sw/lib/perl5/darwin / 
System/Library/Perl/5.8.8/darwin-thread-multi-2level /System/Library/ 
Perl/5.8.8 /Library/Perl/5.8.8/darwin-thread-multi-2level /Library/ 
Perl/5.8.8 /Library/Perl /Network/Library/Perl/5.8.8/darwin-thread- 
multi-2level /Network/Library/Perl/5.8.8 /Network/Library/Perl /System/ 
Library/Perl/Extras/5.8.8/darwin-thread-multi-2level /System/Library/ 
Perl/Extras/5.8.8 /Library/Perl/5.8.6/darwin-thread-multi-2level / 
Library/Perl/5.8.6 /Library/Perl/5.8.1/darwin-thread-multi-2level / 
Library/Perl/5.8.1 .) at /usr/texbin/tlmgr line 31.
BEGIN failed--compilation aborted at /usr/texbin/tlmgr line 31.
~ $

> ----------- Please Consult the Following Before Posting -----------
> TeX FAQ: http://www.tex.ac.uk/faq
> List Reminders and Etiquette: http://email.esm.psu.edu/mac-tex/
> List Archive: http://tug.org/pipermail/macostex-archives/
> TeX on Mac OS X Website: http://mactex-wiki.tug.org/
> List Info: http://email.esm.psu.edu/mailman/listinfo/macosx-tex

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://tug.org/pipermail/macostex-archives/attachments/20090216/98e688b9/attachment.html>

More information about the macostex-archives mailing list