[OS X TeX] TeX Live Utility

Adam R. Maxwell amaxwell at mac.com
Sun Feb 15 17:26:39 CET 2009

On Feb 15, 2009, at 12:51 AM, Paul Fons wrote:

>  I am a little confused.  My TeX Live Utility worked fine when I  
> used it the first few times.  Now, however, I am running into what  
> appears to be the same error mentioned earlier in the mail list  
> caused by having fink earlier in the search path.

Do you have any idea when this may have started?

> The problem, however, is that fink is not the first thing in the  
> search path.  The log from TeXLive is pasted below.  A terminal  
> session shows the path:
> ~ $echo $PATH
> /Library/Frameworks/Python.framework/Versions/Current/bin:/opt/ 
> openmpi/bin:/usr/texbin:/sw/bin:/usr/bin:/bin:/usr/sbin:/sbin:/usr/ 
> local/bin:/usr/texbin:/usr/X11/bin:/opt/feff/feff85:/texprograms:/ 
> opt/etsf/abinit/5.6/bin:/usr/X11R6/bin:/Users/paulfons/bin/FDK/Tools/ 
> osx

This should all be ignored by TLU.

> The bits from TeXLive Utility are reproduced below.  I have no idea  
> where the Path environment is being set, but I don't see fink on  
> it.  Any ideas?
> 2009-02-15 16:57:50 +0900 Notice +[TLMAppController  
> updatePathEnvironment][2305]	Using PATH = "(
>    "/usr/bin",
>    "/bin",
>    "/usr/sbin",
>    "/sbin",
>    "/usr/local/bin",
>    "/usr/texbin"
> )"

This looks correct, and you don't have environment.plist to foul  
things up.  Try this in Terminal, since it's exactly what's being run  
in TLU:

export PATH="/usr/bin:/bin:/usr/sbin:/sbin:/usr/local/bin:/usr/texbin"
tlmgr --machine-readable >/dev/null

-------------- next part --------------
A non-text attachment was scrubbed...
Name: smime.p7s
Type: application/pkcs7-signature
Size: 2415 bytes
Desc: not available
URL: <http://tug.org/pipermail/macostex-archives/attachments/20090215/f542b7e9/attachment.bin>

More information about the macostex-archives mailing list