[OS X TeX] Aquamacs, AucTeX, and preview-latex

Cameron Hooper chooper at umich.edu
Sun Nov 27 18:45:31 CET 2005

On Nov 27, 2005, at 5:48 AM, Peter Dyballa wrote:

> Am 27.11.2005 um 04:11 schrieb Cameron Hooper:
>> I'm using Aquamacs (0.9.6) and installed auctex using the package  
>> from http://yaced.sourceforge.net and installed to /Library/ 
>> Application Support/Emacs as stated in Aquamacs Help. Visiting a  
>> latex file loads auctex, but I don't see any menu items for  
>> preview-latex. I tried typing C-c C-p C-d as suggested in the  
>> preview-latex manual, but emacs responds with C-c C-p is  
>> undefined. I tried adding
>> (load "preview-latex.el" nil t t)
>> to .emacs, but nothing changed. Any suggestions on what I'm doing  
>> wrong?
> Many things -- possibly! Aquamacs Emacs comes with AUCTeX and  
> preview-latex, no installation necessary.

Really? Aquamacs help (Aquamacs for Emacs Veterans -> Latex Support)  
says to install the AucTeX package maintained by Norm Gall at http:// 
yaced.sourceforge.net. Before I did this, visiting a .tex file loaded  
tex-mode, not auctex.

> You not only need to activate preview-latex by loading the ELisp  
> file, you too need to add the path to the preview-latex files:
> 	(add-to-list 'load-path "/Library/Application Support/Emacs/preview")

I assumed Aquamacs did this automatically as it explicitly says  
auctex should be installed at this location. Anyway I added the  

(add-to-list 'load-path "/Library/Application Support/Emacs/site-lisp/ 

but nothing changed. So I then tried

(add-to-list 'load-path "/Library/Application Support/Emacs/site-lisp/ 

Again no change.

> OTOH Aquamacs Emacs is very keen to load recursively everything it  
> finds, even the wrong files. Can you try to remove the recently  
> installed files and directories in /Library/Application Support/ 
> Emacs, but keep the load statement in .emacs?

The only files in /Library/Application Support/Emacs were added by  
auctex installer. I went ahead and deleted them but kept the load  
statement in .emacs. On startup emacs complained that it couldn't  
open load file preview-latex.el. So I deleted the (load "preview- 
latex.el" nil t t) line from .emacs. Now emacs starts but auctex is  
not loaded.

Finally I decided to ignore the Help's suggested save location and  
installed to ~/Emacs, the place I normally add emacs packages and  
deleted the earlier installation. I rearranged the installed files,  
turned around 3 times, spat, added ~/Emacs/site-start.d to my load  
path and loaded auctex.el and preview.el.

It worked! I now have a Preview menu and all works as expected.

Of course, I'm lacking all the nice customisations that putting it in  
the aquamacs recommended directory gave me (automatic loading of  
reftex, bibcite, etc).

Does anyone have experience using aquamacs, autex, and preview-latex?  
Is my experience atypical?


------------------------- Info --------------------------
Mac-TeX Website: http://www.esm.psu.edu/mac-tex/
          & FAQ: http://latex.yauh.de/faq/
TeX FAQ: http://www.tex.ac.uk/faq
List Archive: http://tug.org/pipermail/macostex-archives/

More information about the macostex-archives mailing list