[OS X TeX] Aquamacs, AucTeX, and preview-latex

Peter Dyballa Peter_Dyballa at Web.DE
Sun Nov 27 11:48:40 CET 2005

Am 27.11.2005 um 04:11 schrieb Cameron Hooper:

> I'm using Aquamacs (0.9.6) and installed auctex using the package from 
> http://yaced.sourceforge.net and installed to /Library/Application 
> Support/Emacs as stated in Aquamacs Help. Visiting a latex file loads 
> auctex, but I don't see any menu items for preview-latex. I tried 
> typing C-c C-p C-d as suggested in the preview-latex manual, but emacs 
> responds with C-c C-p is undefined. I tried adding
> (load "preview-latex.el" nil t t)
> to .emacs, but nothing changed. Any suggestions on what I'm doing 
> wrong?

Many things -- possibly! Aquamacs Emacs comes with AUCTeX and 
preview-latex, no installation necessary.

You not only need to activate preview-latex by loading the ELisp file, 
you too need to add the path to the preview-latex files:

	(add-to-list 'load-path "/Library/Application Support/Emacs/preview")

OTOH Aquamacs Emacs is very keen to load recursively everything it 
finds, even the wrong files. Can you try to remove the recently 
installed files and directories in /Library/Application Support/Emacs, 
but keep the load statement in .emacs? This should make it work -- if 
there is another mistake in AUCTeX and preview-latex I can't be of more 
help because Aquamacs Emacs doesn't launch for me because it loads code 
for a version 20 in a subdirectory of /Library/Application 
Support/Emacs and fails.



"Evolution"            o           __o                     _o _
           °\___o      /0~         -\<,              ^\___ /=\\_/-%
oo~_______ /\ /\______/ \_________O/ O_______________o===>-->O--o____

------------------------- Info --------------------------
Mac-TeX Website: http://www.esm.psu.edu/mac-tex/
          & FAQ: http://latex.yauh.de/faq/
TeX FAQ: http://www.tex.ac.uk/faq
List Archive: http://tug.org/pipermail/macostex-archives/

More information about the macostex-archives mailing list