[lucida] Installation issue continues

Bruno Voisin bvoisin at icloud.com
Fri Apr 29 10:03:58 CEST 2022

Hi Raul,

> The path of the Lucida OT fonts is like yours with one addition, which is a directory named /lucidaot1-tex/ as shown below. Could this be causing the problem. This “extra” directory was inserted automatically upon installing the OT fonts following the instructions: I did _not_ insert /lucidaot1-tex/ manually.
> /usr/local/texlive/texmf-local/lucidaot1-tex/fonts/opentype/bh/lucidaot.

That's the cause of your problem: you need to merge the content of lucidaot-tex with the texmf-local tree, not put lucidaot1-tex inside it. For example


goes inside


and so forth.

I did that manually years ago, but was then told by Norbert Preining this can all be done automatically by running in Terminal

	sudo unzip lucidaot1-tex.zip -d /usr/local/texlive/texmf-local

(Just in case, make a copy of your texmf-local before running that command. But it's safe.)

I think that's what's meant when writing "use an unzip program" in INSTALL-TeX.txt, in

	3) Unzip the archive as retrieved.  It unpacks into subdirectories doc/,
	   fonts/, and tex/.  These directories should already exist if you
	   already have a local texmf tree; that's ok.  You must use an unzip
	   program or settings which does *not* create any top-level directory
	   of its own (such as "lucidaot/"), but simply unpacks what is in the
	   zip file.

> Btw, I ran “sudo mktexlsr” while in the /lucidaot/ directory and also from my top-level directory with the same result. 

The location where you run "sudo mktexlsr" from does not matter: mktexlsr recreates the ls-R files for all the texmf trees, namely for MacTeX-2022


So, to summarize, after downloading lucidaot1-tex.zip to your Downloads folder say, the installation procedure is simply to run, in Terminal

	cd ~/Downloads
	sudo unzip lucidaot1-tex.zip -d /usr/local/texlive/texmf-local
	sudo mktexlsr
	sudo updmap-sys --enable Map lucida.map

This takes care of filename-based lookups.

> I followed your lead and entered the following in Terminal
> kpsewhich --progname=xetex --show-path=.otf | tr ":" '\n’
> Here’s what I got
> /Users/RaulMart/Library/texlive/2022/texmf-config/fonts/opentype//   	(This is the same as yours)
> /Users/RaulMart/Library/texlive/2022/texmf-var/fonts/opentype//		(Same)
> /Users/RaulMart/Library/texmf/fonts/opentype//				(Same)
> !!/usr/local/texlive/texmf-local/fonts/opentype//			(Same)
> !!/usr/local/texlive/2022/texmf-config/fonts/opentype//			(Same)
> !!/usr/local/texlive/2022/texmf-var/fonts/opentype//			(Same)
> !!/usr/local/texlive/2022/texmf-dist/fonts/opentype//			(Same)
> /Users/RaulMart/Library/texlive/2022/texmf-config/fonts/truetype//	(Same)
> /Users/RaulMart/Library/texlive/2022/texmf-var/fonts/truetype//		(Same)
> /Users/RaulMart/Library/texmf/fonts/truetype//				(Same)
> !!/usr/local/texlive/texmf-local/fonts/truetype//			(Same)
> !!/usr/local/texlive/2022/texmf-config/fonts/truetype//			(Same)
> !!/usr/local/texlive/2022/texmf-var/fonts/truetype//			(Same)
> !!/usr/local/texlive/2022/texmf-dist/fonts/truetype//			(Same)
> /please/set/osfontdir/in/the/environment//				(Different)
> I know that you have an extra last line that is not supposed to be on my kpsewhich output. It looks like I have a last line (/please/set/osfontdir/in/the/environment//) that is telling me to do something. But I’m not expert with Terminal and have no idea what I should do. Maybe that last line is the key to my issue.

Sorry, my mentioning this last line was misleading. The last line is of no consequence at all for Lucida or any other installed fonts. It corresponds to the variable OSFONTDIR, defined in /usr/local/texlive/2022/texmf-dist/web2c/texmf.cnf as

	% OSFONTDIR is to provide a convenient hook for allowing TeX to find
	% fonts installed on the system (outside of TeX).  An empty default
	% value would add "//" to the search paths, so we give it a dummy value.
	OSFONTDIR = /please/set/osfontdir/in/the/environment

I use it to make LuaTeX aware of the downloadable fonts (called "Downloadable font asset" in Font Book), namely fonts which are not installed by default but are downloaded from the Apple servers whenever the user needs them (ie when pressing the Download button or clicking the "Downloadable font asset" link in Font Book, or opening a document which uses the font).

Slighthly outdated lists of those fonts may be found at


Once downloaded, they are installed (in Monterey) in subfolders (with apparently random names) of


This path varies slightly from macOS version to version, earlier it was Font6 not Font7, etc., and even earlier Assets not AssetsV2.

By default XeTeX searches though all macOS font directories, but LuaTeX (ie luaotfload) only searches through


So I have created a file /usr/local/texlive/texmf-local/web2c/texmf.cnf (running "sudo mktexlsr" afterward) containing


Et voilà !

> I am very grateful for your help. 

Hoping the above will work on your setup,


More information about the lucida mailing list.