[lucida] Problems with Installation

Bruno Voisin bvoisin at me.com
Thu Jul 25 16:05:01 CEST 2013

Le 25 juil. 2013 à 09:53, Thomas Quaritsch <quaritsch at ist.tugraz.at> a écrit :

> I actually did this two days ago, and it worked for me like a charm with a simple unzip (I found the following still in my terminal scrollback buffer)
> tq at tquarits /usr/local/texlive/texmf-local % sudo unzip ~/Downloads/lucida-complete.zip
> […]

What seems to be the key here is that you cd'ed first to texmf-local, before unzip'ping without -d argument.

I just tried that. In your case that would mean

	cd /usr/local/texlive/texmf-local
	sudo unzip ~/Downloads/lucida-complete.zip

It doesn't work on my setup (OS X 10.8.4, aka Mountain Lion):

- A folder lucida-complete is created inside texmf-local, it's not the content of this folder (without the top level) which is put there. So it's exactly as with the -d argument.

- This folder has permissions drwx------ instead of the standard drwxr-xr-x. Hence it cannot be opened except by root:wheel, and accordingly it is not accessible to any user of the Mac.

I don't know whether that's standard behavior of unzip, or whether these are simply the original permissions in the zip archive.

Recently the issue was raised on the MacTeX list, with a user installing from the latest TeX Live DVD and getting 
directories with permissions drwx------ instead of the expected drwxr-xr-x.

This was traced back to the user having a umask setting 077. I have no such setting, nor did I have any notion that there was such thing as a umask before that issue was raised and elucidated by others.

As to unzip: it's the same version as for you, but compilation is different:

Compiled with gcc 4.2.1 Compatible Apple Clang 4.0 (tags/Apple/clang-418.0.60) for Unix on Jun 20 2012.


More information about the lucida mailing list