[lucida] Installation difficulty on MiKTeX

Mike Chapman mike.brigu at gmail.com
Fri Sep 22 22:04:15 CEST 2006

Hi folks,

I learned most of my LaTeX from vol. 1 of the LaTeX Companion, so I'd wanted
the Lucida Bright fonts for about three years. I finally decided to get them
this year, and they are beautiful. I know they're nothing new, but hats off
to the designers for this extended font family.

I was able to install the fonts by following the instructions at source >
fonts > lucidabr > README.TUG on my computer at work, which uses a version
of MiKTeX (probably 2.4.x, can't check just now). I also easily installed
them on my Debian machine, although I needed to fetch a new textcomp.sty for
full use.

Curiously, I ran into trouble on the MiKTeX installation at home. I searched
and read and tried a couple of things, and now I've tried again. I mostly
followed the thread from June/July by Ian Fitzgerald, who uses fptex. Even
though the distributions are different, his main problem seems to be the
same as mine. When using pdflatex on this file:

Hello world.
\emph{Hello world.}
\textsf{Hello world.}
\textbf{Hello world.}
\texttt{Hello world.}

I get such warnings:

(G:\Program Files\Office\MiKTeX\localtexmf\tex\latex\lucida\t1hlst.fd) [1{
psfonts.map}] (lucidatrial.aux) )Trying to make PK font "hlsrt8r" (at 570
"makemf" --verbose "hlsrt8r"
"ttf2pk" -q -t "hlsrt8r"
makepk: "hlhb8r.pk" could not be created.

Warning: pdflatex (file hlsrt8r): Font hlsrt8r at 570 not found
Trying to make PK font "hlhb8r" (at 570 DPI)...
"makemf" --verbose "hlhb8r"
"ttf2pk" -q -t "hlhb8r"
makepk: "hlhb8r.pk" could not be created.

. . . and so on. This makes me think that the problem is the same as
described by Karl Berry in Ian's thread:

    still unable to find certain files. Is this relevant?

Yes, very much so.  That is the whole problem.  Since it doesn't know
that the lucida fonts are outlines, it's trying to look for bitmaps, and
not finding anyway.

Since lucida.map was discussed in that thread and in another discussion I
looked at, I checked and found it to be located at
localtexmf/fonts/map/dvips/lucida.map, where it was put by the unzipping of
the archive. Although the installation did work without a hitch on my work
MiKTeX, I figured maybe this MiKTeX version is different (maybe I changed a
setting somewhere in the past) and maybe it needs a hint. I added a line to
localtexmf/miktex/config/updmap.cfg containing "Map lucida.map" (no quotes
of course).

Then I knew I had to run updmap, and Google told me that under MiKTeX it is
"initexmf -v --mkmap" (again no quotes). The output is telling me that, for
some great and mysterious reason, lucidabr.map and lucida.map are being
ignored. Among the many lines of output, I found these two lines:

not using map file 'lucida.map'
not using map file 'lucidabr.map'

Removing the "Map lucida.map" entry from updmap.cfg and re-running "initex
-v --mkmap" results in the only Lucida-related line being the second line:

no using map file 'lucidabr.map'

>From this I conclude that MiKTeX is being told about lucidabr.map, but is
ignoring it. So no, MiKTeX doesn't know about the outline fonts. The funny
thing is, I cannot find any file lucidabr.map. If it should have been
automatically generated, it hasn't been, and lucida.map is being ignored
even though it exists.

I have fooled with fonts before, including one that was designed for my
institution. Though that particular font was itself far more painful than
the actual installation, I spent enough time on it to have learned that
there is a lot to know about font installation -- I have the feeling that I
am overlooking something trivial. Any hints?
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://tug.org/pipermail/lucida/attachments/20060922/1ba97ccd/attachment.html 

More information about the lucida mailing list