[luatex] lyluatex compile problems

liebrecht at grossmann-venter.com liebrecht at grossmann-venter.com
Sun Jul 29 17:59:49 CEST 2018

a)  Ok good to know that explains the compiling problems fundamentally.
If the manual were a lyluatex file it would have been one of the 
greatest tutorials right there.
What I tried to compile is the manual in the zip download here
Which seemed to be the  lyluatex code, but I am seemingly mistaken.

b) Ok

c) Ok I saw that, but where that was mentioned there was no direct 
compile instruction. The option --shell-escape was mentioned in the body 
text and there was no direct compile command.
"lualatex --shell-escape somefile.tex"
were in the instructions I did not have to ask this question, but it is 
Would be a good idea to add that.

1) Since I cannot compile the manual and use that to learn lyluatex, (my 
preferred latex way to learn is just to work through the code compiling 
the manual. (Last 20+ more years taught me that is by far the best way.)
Is there an indepth lyluatex manual that is compilable with luatex ?
2) Is there an archive with lots of lyluatex document examples combining 
both text and musical notaion in the document ?


On 2018-07-29 11:22, Urs Liska wrote:
> Am 29.07.2018 um 16:31 schrieb liebrecht at grossmann-venter.com:
>> I installed lyluatex by means of texlive-luatex.
>> I then tried to compile the manual (lyluatex.tex) in the luatex 
>> download zip archive as a test.
>> $] latex lyluatex.tex
>> It exits with errors.
>> Obviously then the compiler is not LaTeX.
> There are several issues here:
> a)
> The manual is not written in a lyluatex.tex file but in lyluatex.md,
> which has to be processed with Pandoc. Also the Zip download from
> Github doesn't contain such a file, so I don't know what you actually
> tried to compile.
>> The manual is thorough but I cannot find a single instance of how to 
>> compile a lyluatex file.
>> I must have overlooked it but just cannot find it.
> b)
> lyluatex relies (as the name suggests) on LuaLaTeX, so the basic
> command has to be lualatex, not latex.
> This is stated in the first "Note:" section of the "Usage" section. In
> a slightly more informal way it is also stated in the first paragraph
> of the introduction.
> c)
> As lyluatex invokes LilyPond it needs the privilege to do so. This is
> done by the command line option --shell-escape.
> This is described in some detail in the third "NOTE:" section of said
> "Usage" section
>> So what is the mysterious compile command ?
> lualatex --shell-escape somefile.tex
>> thanks

More information about the luatex mailing list