[luatex] lyluatex compile problems

Urs Liska lists at openlilylib.org
Sun Jul 29 17:22:31 CEST 2018

Am 29.07.2018 um 16:31 schrieb liebrecht at grossmann-venter.com:
> I installed lyluatex by means of texlive-luatex.
> I then tried to compile the manual (lyluatex.tex) in the luatex 
> download zip archive as a test.
> $] latex lyluatex.tex
> It exits with errors.
> Obviously then the compiler is not LaTeX.

There are several issues here:

The manual is not written in a lyluatex.tex file but in lyluatex.md, 
which has to be processed with Pandoc. Also the Zip download from Github 
doesn't contain such a file, so I don't know what you actually tried to 

> The manual is thorough but I cannot find a single instance of how to 
> compile a lyluatex file.
> I must have overlooked it but just cannot find it.

lyluatex relies (as the name suggests) on LuaLaTeX, so the basic command 
has to be lualatex, not latex.

This is stated in the first "Note:" section of the "Usage" section. In a 
slightly more informal way it is also stated in the first paragraph of 
the introduction.

As lyluatex invokes LilyPond it needs the privilege to do so. This is 
done by the command line option --shell-escape.
This is described in some detail in the third "NOTE:" section of said 
"Usage" section

> So what is the mysterious compile command ?

lualatex --shell-escape somefile.tex

> thanks

More information about the luatex mailing list