[luatex] recent tunenc.def fails with lualatex

Rembrandt Wolpert r.f.wolpert at gmail.com
Sun Mar 5 03:18:30 CET 2017

I wonder if this is just my problem...:

after a very recent full update of texlive everything I tried to compile
failed with:

  * fontspec warning: "tu-clash"
  * I have found the tuenc.def encoding definition file but the TU
encoding is
  * not defined by the LaTeX2e kernel; attempting to correct but you really
  * should update to the latest version of LaTeX2e.
  ! Missing \endcsname inserted.
  <to be read again>
  l.252 ...             \UnicodeEncodingName {}{"007E}


The two (newly introduced) lines in tuenc.def which offended my lualatex
(0.95, from texlive 2016) are:

\DeclareTextComposite{\^}             \UnicodeEncodingName {}{"005E}
\DeclareTextComposite{\~}             \UnicodeEncodingName {}{"007E}

After commenting these out the compilation worked fine. Please note,
that the "offending" lines caused no problem when compiling the MWE with
xelatex (but I am using lualatex).

Here's a M(N)WE:

  %\usepackage{luatex85} % un-comment when compiling with lualatex
  %\setmainfont{Brill} % this would be a free and rather comprehensive
  Won't compile under lualatex with newest tuenc.def.
  Compiles fine with xelatex.

Is there just something wrong with my system? And if so, what would be a
remedy (other than commenting the two lines out, which I did to be able
to continue working)?

(MacOS 10.8.5, texlive (mactex) 2016, last update 3 days ago.)


                          - 劉因

More information about the luatex mailing list