[luatex] detailed 'diagnostic' of MikTeX/Lua*/fontspec issues

Evan Cooch evan.cooch at gmail.com
Sat Jun 29 23:16:27 CEST 2013

Just tried the whole exercise again (yes, all of it), but this time 
installing MikteX 'for only me'. I did this to avoid any weird 
permissions errors between 'user' and 'admin' (even though they're the 
same thing on my machines).  I used an even simpler MWE



Lorem  $a$

Still gives the same error -- can't rebuild (or access, or anything) the fontname db. If I comment out the call to fontspec, compiles fine. As soon as fontspec gets involved...crash and burn.

So, we're back to fontspec, and/or luaotfload.

At this point, maybe I could ask someone else out there using MikTeX on  
Windows machine, with all the latest updates installed, to see if they 
can replicate the problem. If not, then its something weird on my 
machines (although I haven't the foggiest what that might be). I've now 
down installs/re-installs about 7-8 times in the past few days, and even 
by random chance alone, you'd think I'd hit the right combination.

Unless of course, the problem lies with fontspec and luaotfload. ;-)

More information about the luatex mailing list