[luatex] [MiKTeX] detailed 'diagnostic' of MikTeX/Lua*/fontspec issues

Evan Cooch evan.cooch at gmail.com
Sun Jun 30 17:30:36 CEST 2013

On 6/30/2013 6:42 AM, Ulrike Fischer wrote:
> Am Sat, 29 Jun 2013 17:16:27 -0400 schrieb Evan Cooch:
>> At this point, maybe I could ask someone else out there using MikTeX on
>> Windows machine, with all the latest updates installed, to see if they
>> can replicate the problem.
> As I already wrote: I can't. I don't have any problems to run a
> small file using fontspec on a current miktex.


>> If not, then its something weird on my
>> machines (although I haven't the foggiest what that might be). I've now
>> down installs/re-installs about 7-8 times in the past few days, and even
>> by random chance alone, you'd think I'd hit the right combination.
> Well perhaps you should reconsider your problem solving strategies.
> Reinstalling 7-8 times doesn't help if the source of the problem
> doesn't lie in the installation.

Which is something you don't know until you've exhaustively tried out 
various install sequences. perhaps the problem was admin versus single 
user? Perhaps the problem was installing ll updates at once, or in a 
more hierarchical fashion? Perhaps the problem was with or without 
anti-virus on? And so on. There are *many* different install sequences, 
and which of could yield either 'success' or 'failure'. Just as some 
LaTeX packages work or not, depending on the order you load them 
relative to other packages (which leads to *lots* of testing).

>> The termination always occurs after it has started scanning my
>> working directory (which happens to be the Desktop for my
>> account, which again is an admin account).
> Then I would suggest to test if it works if you change the working
> directory to a folder with a simple name - the desktop can contain
> problematic chars.

OK -- happy to try, but

1\ then such a 'problem' is an artifact of the new version of fontspec 
(presumably) since during the detailed installs I tried yesterday, it it 
worked fine -- desktop or not -- until the moment I upgraded the files. 
Meaning, fontspec used to have no problem with Desktops. On my other 
machines, I do test compiles of files on my Desktop routinely, with no 
problems. If current fontspec balks at Desktop files now, then I would 
submit that its a bug.

More information about the luatex mailing list