[luatex] detailed 'diagnostic' of MikTeX/Lua*/fontspec issues

Evan Cooch evan.cooch at gmail.com
Sat Jun 29 22:15:34 CEST 2013

Quick followup.

> But, this fails too. Terminates with 'unexpected condition'. But, I 
> think this is spurious since it bombs when it gets to my working 
> directory. It seems to grind through TEXMF and OS just fine.
> But, if I try luaotfload-tool -vv, it doesn't actually print out any 
> loaded fonts.  luaotfload-tool -f doesn't do anything either.
> Thinking my 'tweak' to lualibs-dir.lua might be the culprit, I revert 
> to the original file.
> Alas, no happiness.  I even tried some fonts that are in the OS font 
> subdirectory -- makes no difference.
> After 3-4 other 'experiments', I conclude...

Found an earlier post from Ulrike Fisher pointing out a problem with 
lualatexiniconfig.tex, and unicode-math. I don't think that is the 
issue, but, nonetheless, tweaked the file as follows:

tex.extraprimitives('etex', 'pdftex', 'umath'))

But, not only didn't that immediately fix things, but I didn't expect it 
to, since the compile fails if I don't use unicode-math at all! All I 
need to do is call fontspec, and things crash and burn, no matter which 
font I try to set as main font (in TEXMF or OS).

So, the problem goes beyond unicode-math...

As a related aside, I tried luaotfload-tool again

luaotfload-tool --update --force

and if fails -- exits with 'unexpected condition'. What is strange (or 
telling) is that if I look at it while its running, it shows be th 
blacklisted files, then scans TEXMF and OS fonts, and then starts 
scanning the working directory where I opened the command prompt. Its at 
that point that it fails. Even something simple like

luaotfload-tool -i

fails - same 'unexpected condition'.

So other random bits which might be relevant:

1\ There is a directory C:\USERS\me\$TEXMFCACHE which doesn't exist on 
any of my other machines. It has a couple of subdirs, but is essentially 
empty. If I delete it, and rerun luaotfload-tool --update --force, it 
gets recreated, but is empty -- and, I get an API Error 5: Access is 
denied (which makes no sense since my user account is an admin account!).

2\ In \local\MikTeX\2.9\luatex-cache\generic\names I see the database 
otfl-names.lua. If I open it up, I see all the fonts (including the XITS 
font I used in the MWE - when it was compiling).

3\ If I rename the db file (equivalent to deleting it), I try to rebuild 
use luaotfload-tool --update --force, no new file gets created (not 
surprisingly, since there is an 'exception', the process doesn't finish).

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://tug.org/pipermail/luatex/attachments/20130629/5ed3c5df/attachment-0001.html>

More information about the luatex mailing list