[luatex] updates to various lua* packages breaks..something.

Philipp Gesang Philipp.Gesang at alumni.uni-heidelberg.de
Thu Apr 25 09:43:22 CEST 2013

···<date: 2013-04-24, Wednesday>···<from: Evan Cooch>···

> >I can’t test with windows but it would appear this is permissions
> >related. Run mkluatexfondb -h
> That directive simply brings up the help screen.

There should be line at the bottom indicating the database path.

> This has been so bizarre I did a complete de novo install of MikTeX.
> If I don't update lua* packages, no errors. Once again, the moment I
> do the update, I run into this problem.

There has been an update to CTAN recently.

> I'm the admin account, so in theory, MikTeX (and all its bits)
> should have write permissions.

These lines suggest you could as well run with normal privileges:

    luaotfload | Font names database loaded: C:/Users/my-id/AppData/Local/MiKTeX/2.9/luatex-cache/generic/names/otfl-names.lua
    luaotfload | Scanning TEXMF and OS fonts...

Shouldn’t “C:\users\my-id” be writable to user “my-id”? Of
course, delete the current database first in case it is owned by

> >If you are feeling adventurous, you can locate the file
> >“luaotfload.lua” from your distribution. Make a backup and
> >then comment out the line:
> >
> >   fonts.define.resolvers.file = fonts.define.resolvers.name
> >
> >and see if it helps.
> >
> OK, just tried that - and yes, made quite a difference. No more 'scanning'.
> Does that indicate anything useful?

You can keep it that way if it still finds other fonts.


()  ascii ribbon campaign - against html e-mail
/\  www.asciiribbon.org   - against proprietary attachments
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 198 bytes
Desc: not available
URL: <http://tug.org/pipermail/luatex/attachments/20130425/b7c6715f/attachment.bin>

More information about the luatex mailing list