[luatex] updates to various lua* packages breaks..something.

Evan Cooch evan.cooch at gmail.com
Thu Apr 25 02:04:21 CEST 2013

>>>> Wonder if its related to the following. If I bring up an admin cmd
>>>> console, and run
>>>> mkluatexfontdb -f -vvv
>>>> I get an error:
>>>> mklualatexdb: Windows API Error 5: Access is denied
>>>> mklualatexdb: Data: C://Documents and settings
>>> Sorry, no idea. Maybe you need to pass it to texlua?
>> Sorry, but that seems like a stretch.  Everything worked before
>> worked before.
> I can’t test with windows but it would appear this is permissions
> related. Run mkluatexfondb -h

That directive simply brings up the help screen.

But, I did try

mkluatexfontdb -v

which generated the following:

luaotfload | Updating the font names database:
luaotfload | Font names database loaded: 
luaotfload | Scanning TEXMF and OS fonts...

which is followed by

luaotfload | scaning TEXMF and OS fonts...mkluatexfontdb: Unexpected 

This has been so bizarre I did a complete de novo install of MikTeX. If 
I don't update lua* packages, no errors. Once again, the moment I do the 
update, I run into this problem.

I'm the admin account, so in theory, MikTeX (and all its bits) should 
have write permissions.

> to see where the database is
> located. You need write permissions in that directory.
>>>> Suggestions? Clearly something has been 'broken' during the update -
>>>> at least on Windows machines running MikTeX 2.9.
>>>> Thanks in advance.
>>> Thanks for reporting
>>> Philipp
>> Sure -- not sure what else to report.
>> I think the fact that mkluatexfontdb doesn't run - at all really -
>> is telling. Could it be a corruption of something on this one -
>> updated - system? Suggestions on what to look for?
> File permissions. If the database is being rebuilt over and over
> again, this might be a clue that it cannot be saved to disk. The
> message indicating this would be:
>    luaotfload | Font names database not found, generating new one.
> If it is only updated, then it’s a problem with the lookup. In
> this case, the message is the one you gave in your first post:
>    luaotfload | Updating the font names database:
> If you are feeling adventurous, you can locate the file
> “luaotfload.lua” from your distribution. Make a backup and
> then comment out the line:
>    fonts.define.resolvers.file = fonts.define.resolvers.name
> and see if it helps.

OK, just tried that - and yes, made quite a difference. No more 'scanning'.

Does that indicate anything useful?

More information about the luatex mailing list