[l2h] inline \verb does not work when data on windows and using latex2html from Linux in VBox

Bob van der Poel bob at mellowood.ca
Thu May 10 05:04:32 CEST 2012

This is not a solution ... but since you seem to have identified the
location of the problem have you considered inserting some print
statements right before/after the dbmopen{} calls. See that the value
of TMP, etc. is.

BTW, I don't do Perl ... and every time I see Perl code it reminds me
of the reason :)

Hope this helps.

On Wed, May 9, 2012 at 7:32 PM, Nasser M. Abbasi <nma at 12000.org> wrote:
> An update on what I tried:
> I think the problem is related to dbm(). looking
> at /usr/bin/latex2html.perl  I tried to understand
> how it handles the db opening and closing and why
> that fails when the .tex file is on the mounted
> shared disk vs. when it is not on the mounted disk.
> I could not, since I do not know enough perl to
> understand what it is doing. But my theory i now
> is this:
> It seems to create files for the db itself, under
> TMP to store the verb data as Ross explained before.
> -------latex2html.perl ---------------------------
> sub open_dbm_database {
>    # These are DBM (unix DataBase Management) arrays which are actually
>    # stored in external files. They are used for communication between
>    # the main process and forked child processes;
>    print STDOUT "\n"; # this mysteriously prevents a core dump !
>    dbmopen(%verb, "$TMP_${dd}verb",0755);
> #    dbmopen(%verbatim, "$TMP_${dd}verbatim",0755);
>    dbmopen(%verb_delim, "$TMP_${dd}verb_delim",0755);
>    dbmopen(%expanded,"$TMP_${dd}expanded",0755);
> ------------------------------------------
> I think it is creating these using file naming
> which does not work on the NTFS file system or
> using permissions that are not supported on windows
> file system.
> Even though I made sure the TMP is on Linux by using
> latex2html -tmp /home/me/TMP   foo.tex
> I also did export TMP=/home/me/TMP in addition
> to the above just to be sure.
> So, TMP/ is supposed to be on Linux disk, not windows,
> and I see it is.
> But it seems that somewhere in the db processing
> this chnages? and TMP for that part only goes back
> to NTFS disk (current folder where my .tex file on
> windows disk), and it then tries to make the dbm files
> there, and could not create them, either due to strange
> permission it uses (0755) or something like this.
> (I do not know if it checks for errors from dbm
> anywhere).
> Since the only difference is the file system,
> I think it is related to the dbm files used, since
> that is where the \verb info is stored. I noticed
> that \verbatim perl code is commented out there
> in the dbm() related functions also as you can
> see above.
> What I now do, is copy the folder I want to run
> l2h on to linux, run the makefile there to build
> the html, then copy the folder back to my windows
> disk.
> thanks,
> --Nasser
> _______________________________________________
> latex2html mailing list
> latex2html at tug.org
> http://tug.org/mailman/listinfo/latex2html

**** Listen to my CD at http://www.mellowood.ca/music/cedars ****
Bob van der Poel ** Wynndel, British Columbia, CANADA **
EMAIL: bob at mellowood.ca
WWW:   http://www.mellowood.ca

More information about the latex2html mailing list