[l2h] Poblems with installation

Darrell Ryan darrell at ryan-usa.com
Wed Jul 30 00:06:45 CEST 2003


You are trying to install an old version of LaTeX2HTML so you should probably go get the latest one, however, you will most likely still have the same problem.  I experienced the exact same problem recently on a Win98 installation and for some reason using the -debug command line switch caused the test.bat to complete correctly.  I wouldn't be at all surprised if this resolves this particular issue for you.  Once installed, all my existing stuff converted without a glitch.  No need for -debug on those.  Oddly enough, it just seemed to be necessary for test.bat to complete successfully.

Also are a few other known weird happenings when running LaTeX2HTML on Windows.  Errors conmverting images and what not..  I have copied and pasted here from another email I sent out some time ago, some suggestions that you may want to consider implementing if you run into any further trouble.  Some of these recommendations are surely not necessary, but this is what consistently has worked for me on both NT and 9x.  YMMV.


1.  Don't use the same temp folder as the operating system does.  Make a new
temp folder, \l2htemp or somesuch, for l2h's exclusive use.  Modify
prefs.pm accordingly.  I am using drive F:

$prefs{'TMPSPACE'} = 'F:\\l2htemp';

2.  Also in prefs.pm, make the target directory name l2h.  From your log, it
appears you have already made this mod:

$prefs{'PREFIX'} = 'F:\\l2h';

3.  Find the local initialization file, dot.latex2html-init.  It's in the
same folder as prefs.pm.  If left alone, this will definitely be a problem
(if not now it will be later, so fix it now.)  The "dot" is a result of NT's
inability to correctly parse the filename during decompressing of the
archive.  L2h thinks this file is named .latex2html-init (with leading
period instead of "dot").  I am assuming that 9x will similarly parse this
incorrectly, but even if it is correct you want to rename it.  Leading
periods in filenames can sometines wreak havoc with DOS command
interpreters.  Rename it to something command.com can properly dealt with,
e.g. l2hinit is what I use.  It is
necessary to inform l2h of the change, obviously.  Before running
config.bat, modify the l2hconf.pin file, which during execution of
config.bat is built to l2hconf.pm.  This is the global config file for l2h.

# Local initialization files are usually named  .latex2html-init
# this name is hard-coded as the default with the latex2html script
# It can be changed here, if desired:
# $INIT_FILE_NAME = '.latex2html-init';

Do not just uncomment and change this last line from '.latex2html-init' to
'l2hinit'.  That won't work.  Instead, just leave that line commented and
add this new line:

$INIT_FILE_NAME = $ENV{'L2HINIT_NAME'} || 'l2hinit';

4.  Change the default image type from png to gif.  Not really necessary,
but recommended since many browsers do not correctly render transparent
png's.  Although it may appear that l2h is not correctly rendering a
transparent png, it is actually the web browser that is the culprit.

Note:  some test.bat's have been known to fail (ie not successfully convert images)
if step #4 is not taken.

make this
mod either in l2hconf.pin (before running config.bat) or directly to
l2hconf.pm (after running config.bat):

@IMAGE_TYPES = qw(gif png);

The default has the order reversed, i.e. qw(png gif).  Also be sure this
line is not commented out.

5.  Run config.bat.  If execution seems to stop while checking dvips, just
hit enter a time or two and it will resume.

I noticed from your log that l2h was successful in recognizing GS:

checking for gswin32c... C:\GS\GS7.04\BIN\gswin32c.exe
checking for ghostscript version... 7.04

Many people on Wintel (myself included) will instead get:

checking for gswin32c... no
Warning: Will not be able to generate images due to above failure.

...and similar errors for the netpbm utilitites because we choose not to
have all that stuff in our path.  In case you didn't know, the prefs.pm mod
that takes care of this without having to put GS and netpbm in the path is:

$prefs{'EXTRAPATH'} = 'F:\\gs\\gs7.04\\bin;F:\\netpbm\\bin';

...your paths may vary according to where you installed GS and netpbm,

6.  If all's OK in config.log, run test.bat.  See if your errors go away.

7.  Look at test output with your browser and verify the mathematical
formulae display correctly.

8.  Run install.bat.  Consider placing the l2h\bin folder in your path, so
you can later run latex2html.bat from any directory.  You may also wish to
keep that l2hinit file discussed earlier (for some reason it did not seem to
copy over to the install directory.)  It doesn't really need to go there per
se, but you will probably want to keep a copy of it _somewhere_ before you
remove the expanded archive files that you ran the install from (which are
now safe to delete since it is already "installed" at the destination
folder.")  Copies of l2hinit can be modified and placed accordingly to
facilitate different local configurations (e.g. unique to each project,
person, etc.) without having to all the time modify the l2hconf.pm, which
applies global settings _before_ parsing l2hinit.

  ----- Original Message ----- 
  From: Pablo Bellino 
  To: latex2html at tug.org 
  Sent: Tuesday, July 29, 2003 6:42 PM
  Subject: [l2h] Poblems with installation

  Hi all,
  I'm having some problems with the installation of latex2html-99.2beta8. I have:
  Windows Millennium
  Active Perl 5.6.1
  MikTex 2.3
  Ghostscript 8.00

  Before I ran the install, I changed the followings lines of the file prefs.pm:

  $prefs{'EXTRAPATH'} = 'D:\\archiv~1\\gs\\gs8.00\\bin;D:\\netpbm\\bin';

   $prefs{'PREFIX'} = 'D:\\latex2html';
  #$prefs{'PREFIX'} = '/usr/local';

  Then I  ran install, and the config.log file says:

  config.pl, Release 99.2beta8 (Revision 1.32)
  Accompanies LaTeX2HTML, (C) 1999 GNU Public License.

  checking for old config file (cfgcache.pm)... not found (ok)
  checking for platform... MSWin32 (Windows 32 bit)
  checking for D:\Perl\bin\perl.exe... D:\Perl\bin\perl.exe
  checking perl version... 5.006001
  checking if perl supports some dbm... yes
  checking if perl globbing works... yes
  checking for tex... c:\texmf\miktex\bin\tex.exe
  checking for latex... c:\texmf\miktex\bin\latex.exe
  checking for initex... c:\texmf\miktex\bin\initex.exe
  checking for kpsewhich... c:\texmf\miktex\bin\kpsewhich.exe
  checking for kpsewhich syntax... ok (style=1)
  checking for TeX include path... NONE
  Warning: Will not automatically install LaTeX2HTML style files.
  checking for dvips... c:\texmf\miktex\bin\dvips.exe
  checking dvips version... 5.90a
  checking if dvips supports the combination of -E and -i -S 1... yes
  checking for html4-check... no
  checking for gswin32c... \archiv~1\gs\gs8.00\bin\gswin32c.exe
  checking for ghostscript version... 8.00
  checking for ghostscript portable bitmap device... pnmraw
  checking for full color device for anti-aliasing... ppmraw
  checking for ghostscript library and font paths... built-in paths are correct
  checking for pnmcrop... \netpbm\bin\pnmcrop.exe
  checking if pnmcrop can crop from one direction... yes
  checking for pnmflip... \netpbm\bin\pnmflip.exe
  checking for ppmquant... \netpbm\bin\ppmquant.exe
  checking for pnmfile... \netpbm\bin\pnmfile.exe
  checking for pnmcat... \netpbm\bin\pnmcat.exe
  checking for pbmmake... \netpbm\bin\pbmmake.exe
  checking for ppmtogif... \netpbm\bin\ppmtogif.exe
  checking if ppmtogif can make transparent GIFs... yes
  checking if ppmtogif can make interlaced GIFs... yes
  checking for pnmtopng... \netpbm\bin\pnmtopng.exe
  checking if multiple pipes work... no
  Unfortunately multiple pipes are not reliable on this OS.
  checking for temporary disk space... C:\WINDOWS\TEMP
  creating cfgcache.pm
  creating test.bat
  creating install.bat
  Note: Will install...
        ... executables to   : D:\latex2html\bin
        ... library items to : D:\latex2html

  As far I know, nothing wrong is up to this point. The problem arise when I execute the test.com (fist I changed the environment memory to 1024 of this file).  When the conversion arrives at the conversions of images, in the shell appear>

  Converting image #1
  the search directory of COMMAND is wrong
  too much parameters
  too much parameters

  some more lines like those, and the shell froze. I have been reading the files of installation of the program and I couldn't find the source of the error. It seems to me that the problem is with my system, but I would be appreciate if someone could help me. Thanks.



  latex2html mailing list
  latex2html at tug.org
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://tug.org/pipermail/latex2html/attachments/20030729/60fda8af/attachment-0001.htm

More information about the latex2html mailing list