[texworks] Building Texworks problem on Windows

Stefan Löffler st.loeffler at gmail.com
Sun Aug 23 13:22:08 CEST 2009

Hi again,

On 2009-08-23 12:53, Mehdi Omidali wrote:
> On 8/23/09, Stefan Löffler <st.loeffler at gmail.com> wrote:
>>  * Can the problem be solved by adding
>>        INCLUDEPATH += C:/KDE/include/
>> to TeXworks.pro (somewhere around the other, similar lines you edited
>> there)? (NB: you will probably need to re-run qmake after that)
> Hi Stefan,
> I put the above line in TeXworks.pro and that problem solved

Well, that's good news :).

> but still there is a error which says that:
> C:/KDE/lib/poppler-qt4.lib: no such file or directory
> and a same error for poppler.lib. I looked at C:/KDE/lib but I
> couldn't see these libraries even though I am sure I have installed
> them in my KDE Ver 4.3. Where can I download these libraries or how
> can I compile poppler source to get these libraries.

Well, that's a bit weird again. If you have the mingw version of the KDE
libraries installed, you should have libpoppler.dll.a a and
libpoppler-qt4.dll.a in C:/KDE/lib/.
Now the process is looking for .lib files. The only reason I can think
of is that you are not, in fact, using mingw in some part of the
workflow. So some more questions:
 * Do you have the libpoppler*.dll.a in C:/KDE/lib/?
 * Have you ever installed Qt (with or without KDE on Windows) other
than with the version of KDE on Windows that you are currently using?
 * What does "qmake --version" give?
 * Does it help to call qmake with the absolute path, e.g.
"C:\KDE\bin\qmake" intead of just "qmake"?


More information about the texworks mailing list