[texworks] Building Texworks problem on Windows

Mehdi Omidali mehdioa at gmail.com
Sun Aug 23 12:53:06 CEST 2009

On 8/23/09, Stefan Löffler <st.loeffler at gmail.com> wrote:
> Hi Mehdi,
> On 2009-08-23 07:53, Mehdi Omidali wrote:
>> I tried to build texworks as it is expalined in wiki but after
>> mingw32-make
>> I got lots of errors begining with
>> src\synctex_parser.c:20:  zlib.h:no such file or directory
>> ...
>> but I have installed zlib package of KDE. Any comment is welcome.
> Hm, I'm a bit puzzled by this, as I don't see zlib.h mentioned anywhere
> near line 20 of synctex_parser.c (it's on line 256 for me). And AFAIKS
> there should have been no changes that affect this way of building. So I
> have a few questions for you:
>  * Do you have the latest version of the Tw sources?
>  * If you look at line 20 in synctex_parser.c, does it mention zlib.h
> anywhere in the vicinity?
>  * Can the problem be solved by adding
>        INCLUDEPATH += C:/KDE/include/
> to TeXworks.pro (somewhere around the other, similar lines you edited
> there)? (NB: you will probably need to re-run qmake after that)
Hi Stefan,

I put the above line in TeXworks.pro and that problem solved but still
there is a error which says that:
C:/KDE/lib/poppler-qt4.lib: no such file or directory
and a same error for poppler.lib. I looked at C:/KDE/lib but I
couldn't see these libraries even though I am sure I have installed
them in my KDE Ver 4.3. Where can I download these libraries or how
can I compile poppler source to get these libraries.
ps: I have texworks rev 402.
Best Wishes

More information about the texworks mailing list