[XeTeX] FakeBold vs TikZ

Ross Moore ross.moore at mq.edu.au
Wed Jun 18 02:53:40 CEST 2014

Hi Stefan, Marcin, and others,

On 17/06/2014, at 7:29 AM, Stefan Solbrig wrote:

> Hi,
>>> Just compiled the document under TeX Live 2013 (all updates till the freeze) and still no dot.


I just tried with TeXLive 2013 and 2014 on different Macs.

2013 has the dot!
2014 does *not* have the dot.

For the 2013 installation we have xdvipdfmx-0.7.9
For the 2014 installation,  xdvipdfmx  is version  20140317

I tried using  xelatex -no-pdf  to keep the  .xdv  file.
Then renamed these and copied to the other machine, for processing
with the other version of  xdvipdfmx .
If this would work, then it could identify whether the problem
was in  xdvipdfmx  or due to what is put into the .xdv  file.

No joy came from this test.
Instead, all I get is a fatal error:   Invalid TFM ID: 0 .

It seems that one cannot break up the processing any more,
or at least not in the simple-minded way.
Would one of the developers please explain how to do this 
kind of testing now.

Earlier testing with TeX Live 2012, with  xdvipdfmx-0.7.8 
was just giving the similar error

>>>> Output written on Tikz-test.xdv (1 page, 4856 bytes).
>>>> Transcript written on Tikz-test.log.
>>>> /usr/local/texlive/2012/bin/x86_64-darwin/xdvipdfmx
>>>> Tikz-test.xdv -> Tikz-test.pdf
>>>> [1
>>>> ** ERROR ** TFM: Invalid TFM ID: 0
>>>> Output file removed.



Ross Moore                                       ross.moore at mq.edu.au 
Mathematics Department                           office: E7A-206      
Macquarie University                             tel: +61 (0)2 9850 8955
Sydney, Australia  2109                          fax: +61 (0)2 9850 8114

-------------- next part --------------
A non-text attachment was scrubbed...
Name: logo.png
Type: image/png
Size: 5257 bytes
Desc: not available
URL: <http://tug.org/pipermail/xetex/attachments/20140618/da71cba4/attachment-0001.png>
-------------- next part --------------

More information about the XeTeX mailing list