[XeTeX] XeLaTeX inside chroot jail

Grigory Kalabin grigory.kalabin at gmail.com
Tue Mar 26 20:52:42 CET 2013

Hi everybody!

I'm using xetex 3.1415926-2.2-0.9995.2 (TeX Live 2009/Debian and trying to
run xelatex inside chroot jail.

I've copied following binaries and directories:



Also I tried to copy another tex binaries (tex latex pdflatex xetex) but
it's not helped.

When I try to compile minimal xelatex sample

hello world\end{document}

 everything is fine in standard environment, but when I try to compile it
inside chroot jail I have (pdf file not produced)

Error 32512 (driver return code) generating output;
file simple.pdf may not be valid.

If I compile it with -no-pdf option everything is fine, xdv file produced.

When I run xdvipdfmx -vvv simple.xdv I have no warnings or errors and even
get pdf, but process finished with 139 exit code.

What am I doing wrong?

Kind regards, Grigory.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://tug.org/pipermail/xetex/attachments/20130326/db07d3e8/attachment.html>

More information about the XeTeX mailing list