[XeTeX] Font not found error

Peter Baker psb6m at virginia.edu
Thu Jul 2 16:41:42 CEST 2009

Fr. Michael Gilmary wrote:
> Dr J.D. Billett wrote:
>>   But now I can't get xelatex to find it.  Instead, I get the 
>> following error message:
>> ! Font \zf at basefont="TeX Gyre Termes" at 10.0pt not loadable: Metric 
>> (TFM) file
>>  or installed font not found.
>> \zf at fontspec ...ntname \zf at suffix " at \f at size pt
>>                                                   \unless \ifzf at icu 
>> \zf at set@...
>> l.3 ...x-text,Ligatures={Common}]{TeX Gyre Termes}
> I have the same OS as you do (10.4.11) and I ran the file first with 
> the TL2008 version of TeX Gyre Termes and there was no ffi/ffl 
> ligature. Then I ran Khaled Hosny's python script via X11 ... and with 
> the corrected version of the font, I get the same error message as you 
> do with your example.
> I think Mac OS 10.4 has some bug that doesn't work well with FontForge 
> for altering fonts.
> Does anyone with Leopard have this problem with TeX Gyre Termes --- 
> after running Khaled's script?
Jesse was using a version of the font I sent him. I altered it in 
FontForge just by changing "f f i --> ffi" to "f_f i --> ffi" and tested 
in Leopard (10.5). It worked fine. But I had never installed the earlier 
version on that system.

I'll send it to Jonathan, as he requests.


More information about the XeTeX mailing list