[XeTeX] nopdf option?

Jonathan Kew jonathan at jfkew.plus.com
Mon Dec 1 00:25:55 CET 2008

On 1 Dec 2008, at 12:11, Fr. Michael Gilmary wrote:

> Hi all:
> I'm having trouble printing a pdf generated on Mac OS X (10.4.11) with
> xelatex.
> Specifically, I've got MacTeX2008 and have embedded (among others)  
> Adobe
> Garamond Premier Pro Opticals and the pdf is copied over our network  
> to
> a PC in order to print on a Ricoh Aficio color printer. But the  
> printer
> puts out jaggy fonts! When printed on the HPLaserjet 4000 directly  
> from
> the Mac, the fonts are fine.
> I use the following:
> xelatex -qq -E -r 1200
> I have thought to take the pdf produced and convert it into a  
> Postscript
> file (via the print dialog's PDF drop down) and take the ps file  
> over to
> the PC. (But here in the monastery, I can't just use the printer
> whenever /I/ need it. So, this may have to wait a couple of days.)
> Another option I tried was to produce an xdv file to copy that over to
> the PC so MikTeX can produce it and see what happens. But is the - 
> nopdf
> option still working? I tried to use it to produce the xdv file but it
> returns:
> unrecognized option `-nopdf'
> and produces the pdf as usual.
> I checked xelatex --help, and it lists it as an option.

Check again; I think you'll find it's -no-pdf (with a hyphen in the  

However, you may well have problems moving the .xdv between systems,  
depending how compatible the fonts are on the two machines involved.

Are you using Adobe Reader to print the PDF on the Ricoh? I've seen  
some cases where Adobe products decide to print black text as if it  
were not true black, and so they halftone it and it looks terrible. I  
don't know why this happens. It's not unique to PDFs from XeTeX; I've  
heard of similar behavior from other sources as well.


More information about the XeTeX mailing list