[XeTeX] Type 0 instead of Type 1?

Jonathan Kew jonathan_kew at sil.org
Fri Nov 2 19:03:27 CET 2007

On Fri, 2 Nov 2007 17:41:22 +0100
 "Dirk-Jan Dekker" <djdekker at gmail.com> wrote:

> When I run xelatex with the -output-driver=xdvipdfmx option, then according
> to Adobe Reader, the creator is "xdvipdfmx (0.4)" and the fonts are embedded
> as Type 0 fonts.

OK. (I believe this would behave the same under any Mac OS X version.)

> When I run xelatex *without* the -output-driver=xdvipdfmx option, then it
> uses xdv2pdf and the creator is "Mac OS X 10.5 Quartz PDFContext". Then the
> fonts are embedded as Type 1 fonts, but... the pdf file doubles in size

Yes, xdvipdfmx often produces more compact PDF (though this can depend on the nature of the document).

> xelatex complains with the following warning:
> MacBook.local xdv2pdf[910] <Error>: WARNING: Type1 font data returned by
> OFAStreamPSDownload isn't in the correct format required by the Adobe Type
> 1Font Format specification.

This is a problem that started in Tiger (it didn't happen on Panther), and is triggered by the method used to handle .pfb fonts (which Quartz doesn't support). So you see this if using Computer Modern or other "legacy" TeX fonts in .pfb format, but not for TrueType or natively-installed Type 1 or OpenType fonts. The warnings seem to be spurious; the fonts still look correct in the PDF.

> Is it possible to force xdvipdfmx to embed my fonts as Type 1 fonts?

Not as far as I know. This is simply how (x)dvipdfmx handles them. Does it matter?


More information about the XeTeX mailing list