[XeTeX] XeLaTeX and marvosym

Bruno Voisin bvoisin at mac.com
Tue Feb 27 11:22:49 CET 2007

Le 27 févr. 07 à 10:53, Roberto Durante a écrit :

> - I've tried with the latest trick i know when something doesn't work
> in Mac osx, i've tried with a new user, running the minimal document.
> Everything works smoothly! So, the problem were in my ~/Library/
> texmf, i've erased it and everything returns to work.

This may be another occurrence of the problem of system-wide vs. per- 
user setup, caused by improper combination of sudo and updmap(-sys)  
and resulting in creation within ~/Library/texmf of any of the files


Once created, these files take precedence over those in /usr/local/ 
gwTeX or /usr/local/texlive and, whatever update you may afterwards  
apply using either i-Installer or MacTeX, will stick and keep this  

The usual cure: erase these files, and then: for gwTeX, re-run the  
Configure stage of the gwTeX i-Package; for TeXLive-2007, re-run  
mktexlsr, updmap-sys and fmtutil-sys by hand.

To avoid the problem to show up later, you should make sure,  
regarding font-related additions, to always operate updmap as follows:

- In case you have added map file fragments (such as marvossym.map)  
inside ~/Library/texmf, use

	sudo updmap-sys

- In case you have added map file fragments inside /usr/local/gwTeX/ 
texmf.pkgs (gwTeX) or /usr/local/texlive/texmf-local (TeXLive), use

	sudo -H updmap-sys

This will make sure generated files such as psfonts.map, pdftex.map  
etc. are created within /usr/local instead of ~/Library, making them  
available for maintenance by i-Installer or MacTeX.

That, of course, unless you've explicitly specified the choice of per- 
user configuration; for example, by selecting this at the end of the  
Configure stage of the gwTeX i-Package in Expert mode.

Hope this helps,

Bruno Voisin

More information about the XeTeX mailing list