[XeTeX] I can't find the format file `xelatex.fmt'!

maxwell at umiacs.umd.edu maxwell at umiacs.umd.edu
Thu Aug 9 17:19:11 CEST 2007

Peter Dyballa wrote:
> Am 09.08.2007 um 06:06 schrieb Mike Maxwell:
>> What am I doing wrong?  Is there another way to create this elusive
>> xelatex/xelatex.fmt file?
> You need to invoke fmtutil with an option that makes it create the
> format file. A simple
> 	fmtutil --help
> would reveal the options available. A
> 	fmtutil --missing
> would suffice to generate the missing FMT files.

Yes, I had tried both of those, but writing the msg at 1 AM I forgot to
mention them :-~.  AFAICT, fmtutil does not even try to create the xelatex
format file, although it appears in non-commented-out form in my .cnf
file, and it appears as a line when I run 'fmtutil --catcfg'.

But (as I mention in another reply that I just now sent), when I run
'fmtutil --listcfg', xelatex does *not* appear.  The --help cmd says that
the output of the --listcfg cmd is "filtered to available formats".  So
apparently the xelatex format is not considered an "available format". 
But I don't know what it means for it not to be "available" (i.e. what is
preventing it from being available?), nor do I know whether this means
"available to the system" or "available because I as an individual user
have the corresponding .fmt file" or "available in theory because there's
a line for it in my .cnf file".  (I guess not the latter, since that's
what the --catcfg cmd means, except that the latter doesn't show
commented-out lines.)

> One thing needs to be taken into account: it's the difference between
> a personal and a system wide installation.

Meaning I should log in as root and run the corresponding fmtutil-sys
commands, right?

   Mike Maxwell

More information about the XeTeX mailing list