[XeTeX] I can't find the format file `xelatex.fmt'!

Bruno Voisin bvoisin at mac.com
Thu Aug 9 08:40:59 CEST 2007

Le 9 août 07 à 08:17, Bruno Voisin a écrit :

> Le 25 févr. 07 à 14:50, Pascal de Bruijn a écrit :
>> Does this mean Hungarian hyphenation is breaking my XeTeX
>> installation?
>> Is there a way to circumvent this issue?
> The problem seems to be caused by an incompatibility between XeTeX
> and the Hungarian hyphenation pattern.
> [...]

After re-reading my message I'm realizing I answered a post from  
several months ago. Sorry for wasting bandwidth. I was confused by  
receiving this morning a new message reviving this long-dead thread,  
and didn't notice the original message was from so long ago.

Regarding the new message:

Le 9 août 07 à 06:06, Mike Maxwell a écrit :

> [...]  At any rate, the command
>     fmtutil --enablefmt xelatex
> gives the output
>     fmtutil: initial config file is `/usr/share/texmf/web2c/ 
> fmtutil.cnf'
>     fmtutil: configuration file unchanged.
> and still no xelatex.fmt file.
> What am I doing wrong?  Is there another way to create this elusive
> xelatex/xelatex.fmt file?

Have you tried running in sequence:

fmtutil --disablefmt xelatex
fmtutil --enablefmt xelatex

The error message about an unchanged config file is probably caused  
by fmtutil.cnf containing a line for xelatex already, but for some  
reason the file xelatex.fmt doesn't exist. Alas, when you run  
fmtutil, it notices fmtutil.cnf contains already reference to  
xelatex, thinks the format already exists, and refuses to proceed  

The first command above comments out the line about xelatex in  
fmtutil.cnf. Then the second command uncomments it and then builds  

The same problem often occurs with updmap and updmap.cnf.

I can't test this myself, as I'm on the Mac, not Ubuntu. Hope this  
works though.

Bruno Voisin

More information about the XeTeX mailing list