[XeTeX] MacTex install - no math symbols

Jonathan Kew jonathan_kew at sil.org
Fri Apr 13 15:37:21 CEST 2007

On 13 Apr 2007, at 10:12 am, baptiste Auguié wrote:

> Hi,
> Yesterday I decided to try the MacTeX distribution on Mac OSX. I
> already had some tetex one installed using Fink, but for some reason
> I never managed to have the XeteX working with it.
> Everything works fine using TexShop (both pdflatex and xelatex), but
> when I use another editor (Textmate), or in the terminal, Xelatex
> fails to find some font mapping stuff,
>> *** fontmap psfonts.map not found; texmf.cnf may be broken
>> *** font cmr12 not found in psfonts.map or host system; will
>> substitute Helvetica glyphs
>> <snip>

> I've tried locating these two files, psfonts.map and texmf.cnf and
> they do exist, but I believe there is some conflict with my previous
> Fink install. I've tried to remove it partially, but there is still
> some references to files that were in /sw/share, ... (e.g., locate
> texmf.cnf returns /sw/share/texmf/web2c/texmf.cnf while I deleted
> this texmf folder tree).

The 'locate' command is not necessarily up-to-date, as it relies on a  
filename database that is only refreshed periodically, not  
constantly. That's probably why it is showing you this "deleted" path.

>> kpsewhich psfonts.map returns /Users/baptiste/.texlive2007/texmf-
>> var/fonts/map/dvips/updmap/psfonts.map
> and
>>  kpsewhich texmf.cnf  gives /usr/local/texlive/2007/texmf/web2c/
>> texmf.cnf
> I've tried updating things with sudo texhash, and sudo updmap, but I
> still fails. The resulting pdf contains all the text in the desired
> font, but everything in math mode is just unreadable (figures
> superimposed on each other, ...).
> I've tried reinstalling MacTex again after that with no improvement.
> I'd be quite happy to remove completely the Fink distribution if only
> I knew how (deleted folders cannot be deleted again!), but the fact
> that Texshop works perfectly tells me the MacTeX install must be
> working anyway.

Do you still have some fink-based tex stuff in /sw/bin? If so, and if  
this directory is in your PATH ahead of the /usr/texbin from MacTeX,  
it will be interfering. TeXShop works because it refers to the tools  
by their full paths, rather than searching your current PATH variable.

Some approaches to dealing with this:
* remove /sw entirely, if you no longer need any of the fink stuff  
you've installed in the past
* temporarily rename /sw so that it won't be found, to see if this is  
really causing the trouble
* just remove all TeX-related binaries from /sw/bin, or use the fink  
package manager to remove them
* change your .profile or .bashrc or whatever startup file sets the  
path (depending on the shell you use) to ensure that /usr/texbin  
comes *before* /sw/bin

Once you've gotten the fink stuff out of the way, it might be good to  
remove the (hidden) .texlive2007 directory tree from your home  
folder, so that the formats and other files there get re-created  
without mixing up the tex distributions.



More information about the XeTeX mailing list