[XeTeX] compile xdvipdfmx on Mac OS X (was Re: cmyk colour support broken?)

Jonathan Kew jonathan_kew at sil.org
Fri May 19 23:17:59 CEST 2006

On 19 May 2006, at 9:36 pm, William Adams wrote:

> On May 19, 2006, at 3:41 PM, Jonathan Kew wrote:
>> Is there a libkpathsea.a library in /usr/local/teTeX/lib, and a
>> kpathsea subdirectory in /usr/local/teTeX/include? If so, try running
>> the configure script using:
>> 	LDFLAGS=-L/usr/local/teTeX/lib CFLAGS=-I/usr/local/teTeX/include ./
>> configure
> Yes there is. That command didn't work though.
>> Or alternatively, you can put symlinks in a standard system place
>> such as /usr/local/lib and /usr/local/include that point to the
>> library and header directory, so that configure finds them.
> but that did.
> Thanks!
>> If gwTeX doesn't install the library and headers (I'm not 100% sure),
>> then you'll need to build and install libkpathsea from source; one
>> way to do this would be to "make install" within the TeX/texk/
>> kpathsea subdirectory of the XeTeX source tree.
> FYI I tried this too, but was told there was nothing to be done for
> it --- should I've ``make clean'' first?
> Okay, I've got it compiled and installed now.
> I ran:
> xelatex -no-pdf crj.tex
> and got a .xdv
> I then renamed that to crj.dvi and tried to run xdvipdfmx on it, but
> no joy:
> [Dual-G5-2-3:~/Documents/tex] williama% xdvipdfmx -v crj.dvi
> crj.dvi -> crj.pdf
> DVI ID = 5
> ** ERROR ** Something is wrong. Are you sure this is a DVI file?
> Output file removed.
> Is there something I'm missing?

Yes, apparently! :)

Re-run the xdvipdfmx configure phase, and watch for whether it  
detects the presence of libfontconfig.... if not, it'll build without  
XeTeX support, and in effect you just get dvipdfmx. Sounds like  
that's what you've got.

You probably need to get/build and install the fontconfig and  
freetype2 libraries and header files, or if they're already on your  
system (as part of an X11 installation, for example) you may need to  
tell the configure script where to find them. IIRC, it has a --with- 
fontconfig=.... option (try ./configure --help to check) which you  
can use to point at the X11 library directory where it's installed,  
and then it should look for freetype there as well. Or another option  
is to install fontconfig and freetype development packages with Fink,  
and then point the configure option at /sw/lib or something like that.

Once you have the make process configured with the proper libraries,  
it should build a version of xdvipdfmx that accepts .xdv files.


More information about the XeTeX mailing list