[XeTeX] Mapping=tex-text-->no effect in w32xetex

Jonathan Kew jonathan_kew at sil.org
Fri Jun 16 08:46:37 CEST 2006

On 16 Jun 2006, at 12:28 am, Toralf Senger wrote:

> Hi Jonathan,
> Many thanks for your help! I'm sorry to always open new threads; I  
> have currently only access to my email account via a web interface...
>> Did you check in the .log file to see if there is any error message?
> No error message..
>> Have you tried a minimal plain-tex test, just to check? Something  
>> like:
>    \font\x="Times New Roman:mapping=tex-text" at 12pt
>    \x Hello---world
>    \bye
> Yes, I tried-->no error, three dashes in PDF.
>> should give a message in the .log if it's not found.
> I tried als \tracingmacros=1 which did not give me any better idea  
> of what is groing wrong
>> If this doesn't work...best to report it to Akira
> O.K. I try that tomorrow :((

As you'll see from his message to the list, this should be fixed in  
the new binary, which will be on Akira's site within a day.

> Another thing: I just noticed, that hyperlinks are not active as  
> soon as I load any OTF font and declare it as \rmdefault. When I  
> load something  else residing in the TeX font folder (e.g. a PFB  
> Font), everything is fine ...Hope it is not too frustrating for you  
> to figure out what is going wrong here..

I think I know what would cause this (it'll be the same on both Linux  
and W32, it's an unfinished piece in xdvipdfmx); I'll try to work on  
it soon.


More information about the XeTeX mailing list