[XeTeX] Newbie troubles with XeTeX for Linux

Bruno Voisin bvoisin at mac.com
Wed Aug 23 17:30:43 CEST 2006

Le 23 août 06 à 16:59, Steven Shaviro a écrit :

> When I run xetex from the command line, I get the following:
> kpathsea: Running mktexfmt xetex.fmt
> fmutil: no info for format 'xetex'.
> I can't find the format file `xetex.fmt'!
> When I run xelatex, I get:
> bash: xelatex: command not found.
> I presume all this means that the necessary command files are not
> being found; but besides 'sudo texhash' I don't know what to do to
> correct the situation.
> Any help would be much appreciated.

Trying, without knowing much about Linux: what does the following yield:

kpsewhich fmtutil.cnf

and does the file so found contain the lines:

# XeTeX formats
xetex		xetex		-		*xetex.ini
xelatex		xetex		language.dat	*xelatex.ini

That's what should instruct fmtutil to build the xetex and xelatex  
formats when installing XeTeX.

It may be that an alternative fmtutil.cnf takes precedence over the  
one customized for XeTeX, preventing the creation of these formats.

Bruno Voisin

More information about the XeTeX mailing list